Canadian TV, Computing and Home Theatre Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an LG BD560C blu-ray player, an LG 60PK550 Plasma TV and a VSX-920 Pioneer receiver. I am using all HDMI connections and if I connect my blu-ray directly to the TV, it works perfectly. If I connect it via the receiver, it will only work some of the time. The receiver is connected to HDMI2 on my TV and what is happening most of the time is the TV tries to connect to HDMI4 (it only has 3!) and shows "no signal". Does anyone have any ideas on this? All the equipment is new and able to handle HDMI version 1.4 and I'm using Monster HDMI cables capable of version 1.4. Also, I always turn the TV and blu-ray player on first, then the receiver. Feel free to post any ideas :)
 

·
Super Moderator
Joined
·
56,506 Posts

·
Premium Member
Joined
·
9,233 Posts
The TV needs to detect a signal but, by turning on the receiver last, it appears that the signal isn't getting from the player (through the receiver and) to the TV consistently, so the TV is having trouble detecting which input it should switch to.

Try this sequence when powering on your equipment: player -> receiver -> TV (or receiver -> player -> TV).

-- Edit --
And, of course, what 57 said. :)
 

·
Registered
Joined
·
27 Posts
Another way to think of it... follow the signal path. Turn on the piece of gear that originates the signal (Disc player, HD converter box), then the next piece of gear it goes to (the receiver) then to the TV / monitor, then powered speaker bar/subwoofer etc.
 
1 - 4 of 4 Posts
Top