Canadian TV, Computing and Home Theatre Forums banner

Weird Glitch in Garmin Nuvi 1450 (Map Type/Size)

8174 Views 13 Replies 4 Participants Last post by  57
I wanted to set the address of a hotel I'll be staying at in Davis, California, and save it in "favourites" while I am at home here in Canada. That way, I can jump in the rental car at SFO and drive away without having to type in the hotel address.

I went out to my patio so my Garmin can get a clear shot at the satellite.

I started with "where to" and pressed "address".

I tried changing country to USA. It prompts with "Wyoming" (I'm in BC, nowhere near Wyoming. I was using it in Washington 2 days ago. It seems to have Alzheimer's.)

I touched the "change state/province" bar and spelled out "California" (yes, I spelled it right - did this several times). It prompts with "Connecticut" after I enter the C, but no other state names. I returned to the alpha input screen and finished typing in California. It returns with the message "No matches found".

I tried searching by City but there's no Davis CA or UC Davis CA to be found.

I tried searching "near a different city" and found "Davis CA" near Sacramento, CA, which is correct. So it has Davis CA in the database, but it apparently can't find California as a US state.

This is quite unbelievable since I have used this devise in the Bay area before. So yes, it "knows the way to San Jose".

Has anyone experienced anything like this? Any suggestions on what it happens? Is there a better way to set the address of my hotel in Davis CA in my "favourites"?

1 - 2 of 14 Posts
It is possible the map index is scrambled. Happened to me once. I did a reset and I was able to find places again. Each model reset is slightly different so you might have to Google that sequence.
Why not slip a mircoSD card in and fill 'er up. I put a 1GB card in mine so I could hold the entire dataset. It came with a 256MB card. I think the last edition might have tipped over 1GB so 2GB would be advisable.

Edit: Didn't see your last post.
1 - 2 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.