Canadian TV, Computing and Home Theatre Forums banner

1 - 20 of 20 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Background:
At the beginning of this year, I switched from Bell POTS to voip.ms. I kept my Bell Internet (dry loop now), so I still have the Bell 2wire modem-router. My VOIP adapter is a Linksys RT31P2. It is a router but I use it as an adapter.

I set up the adapter as suggested by voip.ms and Mango’s Linksys page. There have been a number of issues over the last three months and I will mention them briefly, as they might affect the issue I am writing about now.

In January, my adapter was losing registration every few minutes. Voip.ms suggested I switch from toronto2 to montreal2 (which I am still on), and use the IP address for Montreal2 (174.142.75.171) in my adapter settings. They also added a NAT keep alive setting for my account: “this will help for taking the connection as active always… The NAT Keep Alive is an option from the server's end to keep sending keep alive packets to your device in addition to what your device is sending. This is basically to help keep two way communication intact and not lose registration…”

Earlier in March, people could not hear us when we dialed out. On March 15, voip.ms made a routing change on my account. However, this seemed to create another problem: calls coming in would stop ringing after 2-3 rings, although those calling us would continue to hear a ringing sound. Voip.ms suggested this was a hardware problem, or that I should re-set the adapter to its defaults settings. However, I later figured out that the problem was being caused by a setting on the voip.ms Manage DID page: Dial Time Out in seconds. I increased the number of seconds and the problem stopped. The odd part is that the Dial Time Out setting was fine from January to mid-March, i.e. pretty much until voip.ms made a routing change on my account.

Current Problem
:(
So now I am left with one problem, which is not as serious as some of the others I’ve had, but I’d still like to remedy it. When I pick up my phone to make a call, I get a dial tone immediately, but there is about a 10 second wait between when I finish dialing and when I hear the line ringing. Coincidentally or otherwise, when I call home from elsewhere, I also have to wait 10-12 seconds before I hear the line ring. Someone calling me might think that the phone was not working, since 10-12 seconds is longer than you normally wait for the ringing to start.

Voip.ms suggested I change an adapter setting: the Interdigit Long Timer. It was at 10 and they suggested I change it to 0. However, this did not seem to make a difference.

My dial plan, might be a factor, so here it is:

(<:1416>[2-9]xxxxxx|1[2-9]xx[2-9]xxxxxxS0|[2-9]xx[2-9]xxxxxxS0|*xx|*xx.|[3468]11|911S0|822|0|00|[2-9]xxxxxx|4XXX|xxxxxxxxxxxx.)

Voip.ms suggested I remove the period right before the last bracket, but that did not seem to make a difference either.

I am beginning to think that there is something about the routing change that voip.ms made on March 15 that is causing these recent problems. However, they don’t see it that way, and I agree that a routing change for an outgoing call shouldn’t affect the time it takes for an incoming call to connect (although perhaps it is the cause of the outgoing delay). And I don’t recall this being a problem In Jan- Feb; there was a delay, but 3-4 seconds rather than 10.

I would appreciate any suggestions. Thanks in advance.
 

·
Registered
Joined
·
877 Posts
Changing the interdigit long timer and removing the period before the last bracket is an interesting solution to your problem.

Let's look at your outgoing and incoming calls separately. Dial 4443# for the echo test. Then dial 604-299-9000, which is a recorded message so you won't be bothering anyone. Is there a difference between the amount of time it takes to connect your call?

For me, the echo test is near instant, and the 604 number takes about 1.5 or 2 seconds to start ringing. If your results are different from mine, try switching from Value to Premium routing or vice versa and test the 604 number again. (The echo test won't be affected by switching your routing.) What happens this time? (If the results are the same, look at your CDR to verify that you correctly changed your routing.)

With regards to your incoming calls, try routing your DID to the echo test. This way we remove your equipment from the equation and eliminate that as a source of the problem. Do you still have the 10 second delay when calling from multiple phones? You may wish to try, for example, a cell phone and a landline to see if there is any difference. If you still have the problem, it's likely something you can't fix and should be pursued further with VoIP.ms.

Let us know how things go. Good luck,
m.
 

·
Registered
Joined
·
405 Posts
My dial plan, might be a factor, so here it is:

(<:1416>[2-9]xxxxxx|1[2-9]xx[2-9]xxxxxxS0|[2-9]xx[2-9]xxxxxxS0|*xx|*xx.|[3468]11|911S0|822|0|00|[2-9]xxxxxx|4XXX|xxxxxxxxxxxx.)
The 7 digit dialing may be an issue with your outgoing pause. You have both the 7 digit and 10 digit dialing, so after the first 7 digits the ATA is going to wait to see if you keep on going before it adds the 1416 to the front of the dialed #. Does the outgoing pause happen when you use 11 digit dialing (1[2-9]xx[2-9]xxxxxxS0)?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Let's look at your outgoing and incoming calls separately. Dial 4443# for the echo test. Then dial 604-299-9000, which is a recorded message so you won't be bothering anyone. Is there a difference between the amount of time it takes to connect your call?

...
With regards to your incoming calls, try routing your DID to the echo test. This way we remove your equipment from the equation and eliminate that as a source of the problem. Do you still have the 10 second delay when calling from multiple phones? You may wish to try, for example, a cell phone and a landline to see if there is any difference. If you still have the problem, it's likely something you can't fix and should be pursued further with VoIP.ms.

m.
Hi Mango:

Thanks for these suggestions. Here are the results of my tests:

The call to the echo test took 10 seconds to connect.
The call to the 604 number took 14 seconds to connect.

I then switched to Value routing:
The call to the 604 number took 13 seconds to connect.

I have 2 DIDS, so I tried these tests with both, and the results were pretty much the same. I also tried calling the DID on the sub account from the DID on the main account, and that took 20 seconds. Calling from the subaccount to the main account usually produces a fast busy signal, but that only took about 10 seconds.

The biggest change was when I tested the incoming calls and routed my main account DID to the echo test. When I called that DID from my cell phone, I heard the echo test message in 3 seconds! I tried it a couple of times to make sure. When I called that DID from the subaccount DID, I heard the echo test message in 10 seconds, which makes sense, as I would be encountering the dial-out lag of the subaccount DID.

The only other piece of information that may be useful is that I’ve noticed when I log into the voip.ms portal, my main DID sometimes shows no registration, even though the light for that line on the adapter is on. When I refresh, it always appears as registered.

I’m not sure what the significance of these results is, so if you can help interpret, that would be great.
 

·
Registered
Joined
·
555 Posts
I think this is the same as this voip.ms issue -> LINK

Check and see if changing your voip servers temporarily helps with the scenario where "... the ringing comes 8-10 seconds after you dial the number... ".

Remember to switch it back afterwards.
 

·
Registered
Joined
·
877 Posts
Based on your results, it looks like the issue is something to do with your equipment. My first guess would be your router, but I haven't actually run into this one before.

If you feel like tinkering, is it possible to set your 2Wire modem into "Bridge Mode", and use your RT31P2 as your router? If you don't know how to set your 2Wire modem that way, let us know what model of 2Wire modem you have and we can try to look further.

m.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #7
The 7 digit dialing may be an issue with your outgoing pause. You have both the 7 digit and 10 digit dialing, so after the first 7 digits the ATA is going to wait to see if you keep on going before it adds the 1416 to the front of the dialed #. Does the outgoing pause happen when you use 11 digit dialing (1[2-9]xx[2-9]xxxxxxS0)?
I always dial 10 digits rather than 7 – must be a habit. So I don’t think the ATA is waiting for me to dial more. I just tried dialing a 1 in front of the area code (11 digits) and still got a 10 second delay. The outgoing pause happens when I dial a long distance number (11 digits) as well.

I copied my dial plan, probably from voip.ms, and I’m not knowledgeable enough to make changes to it. So unless there is another issue with it, I don’t think it’s the cause.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
lawman,

I changed to New York but that didn’t make a difference. I’m getting this problem on both my DIDs and they are on different servers, although Canadian in both cases.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #9
Based on your results, it looks like the issue is something to do with your equipment. My first guess would be your router, but I haven't actually run into this one before.

If you feel like tinkering, is it possible to set your 2Wire modem into "Bridge Mode", and use your RT31P2 as your router? If you don't know how to set your 2Wire modem that way, let us know what model of 2Wire modem you have and we can try to look further.

m.
My 2Wire modem is a 2701-HG-G. I don't know how to set the 2Wire into Bridge Mode. But I may not want to, as I use both the wired and wireless router features of the 2Wire, and the RT31P2 is not a wireless router. So I would not want to use the RT31P2 as my router if that meant I could not use a wireless connection.

I would be willing to buy another ATA, like the PAP2T-NA, or even another modem-router, if I thought it would resolve some of these issues that I have been having. I’m just not sure it’s a hardware issue, as this delay in connecting started at the same time that voip.ms made a routing change on my account. However, it could be that my hardware started to malfunction at this time also, and if the evidence points to a hardware problem…
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
I installed a softphone (X-Lite) on the advice of voip.ms. My time between dial tone and ringing when I call out with the softphone is much better: 3-4 seconds instead of 10-12 seconds. When I call in using the softphone, the delay is more or less the same as when I call in from an external number: 9-10 seconds. Voip.ms thinks it is something directly related to the Adapter I am using and its configuration, and that I should “verify my settings”. In fact, the settings I am using are a combination of Mango’s and ones voip.ms suggested along the way to address previous problems.

Does a softphone make use of my adapter and its settings in the same way as a normal phone? And if so, how can there be such a marked difference in the delay? I noticed that the softphone seems to have its own dial plan. Is it otherwise relying on the adapter settings? I thought the purpose of the softphone testing was to take my hardware out of the equation, but perhaps this is not so.

Thanks.
 

·
Registered
Joined
·
64 Posts
Actually using the softphone totally removes the ATA from the equation; the only parts of your network still being used are the router and the modem (or in your case just the Bell 2wire modem-router).
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
Thanks, Peter T. With the ATA identified as the most likely problem, I have now replaced my RT31P2 with a brand new PAP2T-NA. And that eliminated the 10-12 second delay between finishing dialing and start of ringing that callers experienced when they called me.

The delay when calling out was still there. So I replaced the default Dial Plan that came with the PAP2T-NA with Mango’s North American 10-digit dialing plan,

( [23456789]11 | *xxx. | <:1>[2-9]xx[2-9]xxxxxxS0 | 1[2-9]xx[2-9]xxxxxxS0 | 011xxxxxxx. | [#*x][*x][*x][*x][*x][*x][*x][*x][*x][*x][*x][*x]. )

and that reduced the delay to 3-4 seconds, which is fine by me. I had tried that Dial Plan with the RT31P2, but it did not help. Also, pressing # after dialing didn’t help either with the RT31P2. I’m told the RT31P2 was not a Sipura product, whereas the PAP2T-NA is, so perhaps that accounts for the different behaviours.

I have not implemented any other of Mango’s Linksys ATA settings suggestions, except for changing the Ring Waveform to Sinusoid on the Regional tab, to get the ring to sound like a normal one. The phones are working now, and perhaps I should not change any other settings unless I encounter a problem. For instance, Mango, you recommend turning on NAT Mapping and NAT Keep Alive if the ATA is behind a router. My ATA is behind the Bell 2-Wire modem-router, but NAT Mapping Enable and NAT Keep Alive Enable are set to No by default. If everything is working as is, should I still change them to Yes? Or is better to adopt an If it Ain’t Broke approach?

Thanks for the help.
 

·
Registered
Joined
·
64 Posts
I am using the exact same dial plan.

I am behind an ASUS RT-N16 router using Tomato. I did change the NAT settings though.

I gather though that your times are basically similar between calls using the softphone and the PAP2T based ones; if so, all seems good :)
 

·
Registered
Joined
·
877 Posts
With regards to NAT Mapping and NAT Keep Alive, turning this off can sporadically cause incoming calls to go directly to voicemail. It's possible it could work at the defaults, but turning these on won't cause any problems, other than using a very very negligable amount of bandwidth. The recommendations on my blog are meant to configure the ATA to mimic a landline as closely as possible, however the great thing is we have the freedom to configure them any way we want. If you like it a different way, then that's just fine too :)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Well, now it is broke, so I am going to fix it. Everything looked good yesterday when I changed my ATA from a RT31P2 to a PAP2T-NA, but today when I try calling home, I get a fast busy signal. I don’t have voicemail set up on voip.ms, so if that is what it is trying to do, it won’t succeed. So, assuming voip.ms is not having problems (I can’t access their site from work), when I get home I am going to turn on NAT Mapping and NAT Keep Alive and make the other changes that you recommend. Too bad it waited til I left the house to misbehave.
 

·
Registered
Joined
·
594 Posts
I AM ALSO GETTING THE EXACT SAME ISSUES AS REPORTED BY ALPHONSE

I noticed this first about 2-3 months ago. It wasn't a big deal at the time as it was pretty random. I was also having an issue with my cordless phones at the time which I thought perhaps it was the phones I was using. (Which have been now been replaced)

Over the course of the last month, I'd say this has been happening about 90-95% of the incoming/outgoing calls.

Just like Alphonse, I initiate an outgoing 10 digit call (or an 11 digit toll free call) and have to wait about 10 seconds or more before I start hearing any ringing. Also, when calls are placed to my DID, there is a slightly shorter delay (7-8 seconds) before any ringing is heard from the caller. NOTE: Actually noticed sometimes if someone calls my DID, there is no ringing sound on their end, yet it is ringing at home and I answer. Its like someone calls me, there is dead silence, then all of a sudden the caller hears me say "hello".

I also have a Bell 2Wire Modem just as Alphonse, but I'm using the SPA2102 ATA. I've spent time trying to trouble-shoot by rebooting/etc.. checking settings like my Dial plan ( 911S0 | *xxx. | <:1>[2-9]xx[2-9]xxxxxxS0 | 1[2-9]xx[2-9]xxxxxxS0 | 011xxxxxxx. | [*x][*x][*x][*x]. ) but this does not change the situation in the slightest.

I'm on the toronto server (I have switched to the montreal, but this didn't change anything).

It hasn't been that huge of a deal on outgoing as my family has grown accustom to the pause, but just as Alphonse stated, I wouldn't want important callers to hang up when calling me thinking the calls isn't being put through. Now I come onto this thread and see the exact samething being reported by another user, tells me this most likely has something to do with voip.ms .

djino
"I assume if I contacted voip.ms I'd get the same sort of treatment by a rep saying its an issue with my ATA?"
 

·
Registered
Joined
·
555 Posts
Well, now it is broke, so I am going to fix it. Everything looked good yesterday when I changed my ATA from a RT31P2 to a PAP2T-NA, but today when I try calling home, I get a fast busy signal. I don’t have voicemail set up on voip.ms, so if that is what it is trying to do, it won’t succeed. So, assuming voip.ms is not having problems (I can’t access their site from work), when I get home I am going to turn on NAT Mapping and NAT Keep Alive and make the other changes that you recommend. Too bad it waited til I left the house to misbehave.
When you get a fast busy signal, just make sure that the server you think you are on is also reflected in the POP server column under "Manage DIDs" for your DID#.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
Djino: I seemed to have solved the delay problem by replacing my ATA: the caller doesn’t hear a delay before ringing starts, and changing the Dial Plan solved the delay problem for outgoing calls. I had changed Dial Plans while using the RT31P2 as an ATA, but that did not help. So I blame the RT31P2. I don’t know anything about the SPA2102 but perhaps that is the cause? Voip.ms had me install a softphone, and the delay on outgoing calls didn’t happen.

Regarding my bigger problem, i.e., incoming calls getting a fast busy signal after 10 seconds of silence: Lawman: yes, the same server is listed both on my ATA interface and the voip.ms one. I managed to go home and implement more of Mango’s settings, but that didn’t help. By the way, I was able to call out through all this. I chatted with Voip.ms, and everything looked OK from their side. They asked for 3 examples of incoming calls that did not go through, so I sent then the CDRs. We did not resolve the problem.

Back at work, I called home, and Lo and Behold, I got through! My spouse told me that both DIDs had rung a few times after I left, and there was a faint voice at the other end. One of my DIDs is only used for outbound faxing and as a backup to the main DID, so no-one would even know that number except voip.ms. So I think that voip.ms must have been testing and then done something at their end to remedy the incoming problem after our chat, and my changing ATAs yesterday may have been coincidental.

However, now I’m told we can’t call out. So the problem is reversed. And when I called in, my voice was echoing more than I’ve ever heard it. So the saga continues….
 

·
Registered
Joined
·
14 Posts
Discussion Starter #20
I chatted with voip.ms again tonight. They have not made any routing changes today, so they pointed to the ATA, and/or the router. They suggested I upgrade the ATA firmware. So I upgraded to 5.1.6 from 3.1.15. Even the 5.1.6 version dates from 2007, so it is too bad that an ATA I bought 3 days ago did not even have 2007 firmware on it. And it is a legitimate PAP2T Voip.ms also suggested “the router may be checked for any likely port blocking. Forwarding SIP 5060 UDP to the ATA's IP is also suggested”.

However, I’ve had voip.ms for over 3 months and haven’t touched the router. Mind you, my experience has not been trouble free. But I think I will give the PAP2 a couple of days with its new firmware before making further changes, including disabling SIP ALG (thanks for the link, Mango).

Much as this has been an interesting experience, I’m really hoping I can get to the point where I can just forget about my voip when I’m not actually using it.
 
1 - 20 of 20 Posts
Top