Canadian TV, Computing and Home Theatre Forums banner
181 - 200 of 299 Posts

·
Registered
Joined
·
10 Posts
If your DHCP request looks like a duck and quacks like a duck...
File... Dude.... Bro....

You have gotta fill me in on how you do this. It can't be that difficult and I have gotta be missing something simple.

Please PM... tell me how you are doing it with no Actiontech. Please Please Please.

I worship you !!!

My only requirement is that I must use my own router for public access.
 

·
Registered
Joined
·
965 Posts
Discussion Starter · #183 ·
I don't have things setup like the Actiontec, I continue to use the old method where my set top boxes get 10.x.x.x addresses. I don't use the Beam app so I don't really care. Trying to replicate the exact environment the Actiontec provides is just too much trouble.
 

·
Registered
Joined
·
10 Posts
I don't have things setup like the Actiontec, I continue to use the old method where my set top boxes get 10.x.x.x addresses. I don't use the Beam app so I don't really care. Trying to replicate the exact environment the Actiontec provides is just too much trouble.
So do you have the hole home PVR working??

I have three receivers and like to watch content on the PVR from all three locations.
 

·
Registered
Joined
·
12 Posts
Hi. Based on your description, I successfully replace the router from Bell with a Cisco 7301.
Next step, I plan to remove the ONT and connect the fibre directly to my router SFP+ port.
Here's a documentation I found for I-240G-B: https://lafibre.info/images/doc/201012_ont_alcatel-lucent_7330_manual.pdf
I read that you know there is a timeslot configured in this ONT. Have you ever enter the configuration page of this ONT? Could you please share something you have tried?

Thank you.
 

·
Registered
Joined
·
102 Posts
From FIle:
Routes won't do it.

The router gets an IP address on the IPTV network VLAN itself - one for the entire house. It then forwards multicast traffic as appropriate based on the routes it has been told (from the DHCP response) and also NATs to the IPTV network when appropriate. The DHCP server for it requires the DHCP request to look a specific way (including the serial number of the Actiontec itself).

The Asus has no existing method to do this (essentially being connected to two WAN networks).
End quote
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Well its clear that the VLAN34 works and is separate from internet and VLAN35.
Without internet I can still get TV. So its definitely a different wan configuration. Not sure if the action tech actually gets a 10.x.x.x address or only the STBs. Im not convinced yet that a router cannot handle and route the 10.x.x network just yet. FILE, can you show me the few lines where the network asks for the serial number of the actiontech. I see references to mac addresses in my wireshark captures but not the serial number request??
 

·
Registered
Joined
·
965 Posts
Discussion Starter · #188 ·
I don't have the wireshark captures from the past, and it's not requesting. It's in the DHCP client options if I remember right. There's tons of stuff there.
 

·
Registered
Joined
·
12 Posts
From FIle:
Routes won't do it.

The router gets an IP address on the IPTV network VLAN itself - one for the entire house. It then forwards multicast traffic as appropriate based on the routes it has been told (from the DHCP response) and also NATs to the IPTV network when appropriate. The DHCP server for it requires the DHCP request to look a specific way (including the serial number of the Actiontec itself).

The Asus has no existing method to do this (essentially being connected to two WAN networks).
End quote
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Well its clear that the VLAN34 works and is separate from internet and VLAN35.
Without internet I can still get TV. So its definitely a different wan configuration. Not sure if the action tech actually gets a 10.x.x.x address or only the STBs. Im not convinced yet that a router cannot handle and route the 10.x.x network just yet. FILE, can you show me the few lines where the network asks for the serial number of the actiontech. I see references to mac addresses in my wireshark captures but not the serial number request??
Exactly. The router will NAT the traffic from IPTV to VLAN 34. And I'm pretty sure if you have more than one TV installed, the additional TV will be plugged into a normal Ethernet port which obtain a internal IP address.

Also, I believe if you just put the TV box and computers in a same network and configure your router to obtain IP address from both VLAN, everything works normal.

BTW: Now I'm considering to replace the ONT with my Cisco 7301 :)
 

·
Registered
Joined
·
12 Posts
I found something about the STB behind NAT of FibreOP TV...
If we configure NAT rules like these at router:

Code:
ip nat inside source route-map FibreOP-Internet interface GigabitEthernet0/0.35 overload
ip nat inside source route-map FibreOP-TV interface GigabitEthernet0/0.34 overload
!
access-list 100 deny   ip any 10.224.0.0 0.0.128.255
access-list 100 permit ip any any
access-list 101 permit ip any 10.224.0.0 0.0.128.255
access-list 101 deny   ip any any
!
route-map FibreOP-Internet permit 10
 match ip address 100
!
route-map FibreOP-TV permit 10
 match ip address 101
(If the destination IP address is belongs to network 10.224.0.0/20, then NAT it to VLAN 34, otherwise, NAT it to VLAN 35).

This will make STB bootable and able to receive TV signal. However, every TV program can only be played for about 5 seconds, later on, a message said "lost signal" appeared. However, you can always choose another channel and switch back to continue viewing.

P.S.: I read the NAT translation table and found that there is NO translation for 10.224.0.0/24 network after boot STB. It seems that watching channels does not require a NAT translation.
 

·
Registered
Joined
·
452 Posts
The 5 seconds of playing is expected, as after 5 second the stream switches from unicast to multicast, which isn't routed.

Sent from my SGH-I317M using Tapatalk
 

·
Registered
Joined
·
12 Posts
Hi AtlanticRebel,
Thanks for your hint! Do you have anything/experiences for the multicast part to share?
Since the original Actiontek router can serve multiple STBs with private IP addresses, there must be some way to route those packets.
 

·
Registered
Joined
·
452 Posts
It's using some custom DRIPE(Dual Routed IP Edge), as for the multicast, I haven't taken the time to sniff out what is exactly setup. I also think there was some variant of mDNS running for the now defunct beam app.
 

·
Registered
Joined
·
1 Posts
First I want to thanks for all of the people that posted information in this thread, helped a lot in understand how Bell runs their network.

I recently configured my EdgeRouter Pro to work with my Bell Internet service. Running 1.5.0 firmware. 2 most important parts that make the PPPoE connection to work:

Code:
set interfaces ethernet eth0 vif 35 pppoe 0 mtu 1492
Code:
set firewall options mss-clamp mss 1440
Haven't played too much with the mss clamp size to see if can be tuned better. I was getting above 175/175 so I was happy.

Here's an brief working example config:

Code:
firewall {
    name pppoe0-in {
        default-action drop
        rule 1 {
            action drop
            description "drop invalid"
            log disable
            protocol all
            state {
                established disable
                invalid enable
                new disable
                related disable
            }
        }
        rule 2 {
            action accept
            description "allow established"
            log disable
            protocol all
            state {
                established enable
                invalid disable
                new disable
                related disable
            }
        }
    }
    name pppoe0-local {
        default-action drop
        rule 1 {
            action drop
            description "drop invalid"
            log disable
            protocol all
            state {
                established disable
                invalid enable
                new disable
                related disable
            }
        }
        rule 2 {
            action accept
            description "allow established"
            log disable
            protocol all
            state {
                established enable
                invalid disable
                new disable
                related disable
            }
        }
    }
    options {
        mss-clamp {
            interface-type pppoe
            mss 1440
        }
    }
}
interfaces {
    bridge br0 {
        address 10.4.0.1/23
        aging 300
        description home
        hello-time 2
        max-age 20
        priority 0
        stp false
    }
    ethernet eth0 {
        duplex auto
        speed auto
        vif 35 {
            description bell-internet
            mtu 1500
            pppoe 0 {
                default-route auto
                firewall {
                    in {
                        name pppoe0-in
                    }
                    local {
                        name pppoe0-local
                    }
                }
                mtu 1492
                name-server auto
                password ****************
                user-id b1******
            }
        }
    }
    ethernet eth1 {
        duplex auto
        speed auto
    }
    ethernet eth2 {
        duplex auto
        speed auto
    }
    ethernet eth3 {
        duplex auto
        speed auto
    }
    ethernet eth4 {
        bridge-group {
            bridge br0
        }
        duplex auto
        speed auto
    }
    ethernet eth5 {
        bridge-group {
            bridge br0
        }
        duplex auto
        speed auto
    }
    ethernet eth6 {
        bridge-group {
            bridge br0
        }
        duplex auto
        speed auto
    }
    ethernet eth7 {
        bridge-group {
            bridge br0
        }
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
service {
    dhcp-server {
        disabled false
        shared-network-name home {
            authoritative disable
            subnet 10.4.0.0/23 {
                default-router 10.4.0.1
                dns-server 10.4.0.1
                lease 86400
                start 10.4.0.100 {
                    stop 10.4.1.254
                }
            }
        }
    }
    dns {
        forwarding {
            cache-size 150
            listen-on br0
        }
    }
    nat {
        rule 5000 {
            description pppoe0-nat
            log disable
            outbound-interface pppoe0
            protocol all
            type masquerade
        }
    }
}
 

·
Registered
Joined
·
262 Posts
samuelkadolph:
I think you might have posted in the wrong thread... This one is about FiberOP, which doesn't use pppoe.
 

·
Registered
Joined
·
2 Posts
This has probably been beaten to death, but would it be possible for someone to post scheenshots of their relevant Tomato or DD-WRT config pages *with* IPTV working? I have FibreOP internet/phone/pvrs and would like to trash the ActionTec.

EDIT: If raw screenshots are posted, I will edit and incorporate them into a guide and post it publicly so that it may be referred to, hopefully adding value.
 

·
Registered
Joined
·
4 Posts
Can the Linksys WRT1900AC be used in this scenario?

I was wondering if the Linksys WRT1900AC is compatible with this network mentioned by the OP. I know in a firmware patch a while back, they added support for VLANS. I have had it up to here with that ActionShit router and I want to invest into some worthwhile and can handle my heavy network loads.
 

·
Registered
Joined
·
55 Posts
I am currently running a Tomato router with FibreOP Internet service only (got rid of my Actiontech). My current config works and I have internet coming into the Tomato router on VLAN 35. However, I'm planning on getting TV service soon. I would like to know if the configuration below should work without using the Actiontec for adding FibreOP IPTV:



The Tomato router is located in the den in the basement in the relative center of the house (as opposed to beside the ONT) in order to provide reliable wireless to the basement and 1 floor above (my house only has 2 floors). The ONT is located in the garage on the wall, and I have a long Ethernet cable running from the ONT to the WAN port on the Tomato router in the basement den. I have a 2nd Ethernet cable running parallel to the first one back FROM the Tomato router on port 4 to a managed switch in the garage. The Tomato router provides DHCP to wired and wireless clients connected to it, and clients connected to the managed switch.

- Ports 1, 2, 3 and 4 are on my local private LAN (br0), with ports 1, 2 and 3 untagged so they are only on the private LAN, which will connect to my game consoles in the Den, which are very close to the Tomato router. There will be no STB in the den, but if I added one later I will just re assign either port 1, 2 or 3 to VLAN 34.

- Port 4 is tagged to my private LAN (br0), my guest LAN (br1) and VLAN34 for IPTV. Port 4 will be connected to a managed switch on a port that is also tagged to VLAN 32, 33 and 34.

- 3 ports on the managed switch will be tagged VLAN 34 and set to priority 4, and have STB's connected via Ethernet to wall ports upstairs.

The other ports on the managed switch will be assigned VLAN 32 or 33 so they are linked to my private and/or public LAN as needed.

Should this config work, or am I missing any details?

Another question I had was, do the STB's need to be connected to a TAGGED port on VLAN 34 or can they simply be connected to a port that is on VLAN 34 untagged?

Thanks!

EDIT:

After reading this entire thread, I realize now there are very few (of any) people who have gotten the TV service working without using the ActionTech at all. Sounds like I'll probably end up going with AtlanticRebel's method of using a dumb switch between the ONT and the router, and connect the ActionTech to the dumb switch and switch from RFC to PPPoE to disable DHCP.
 
181 - 200 of 299 Posts
Top