Canadian TV, Computing and Home Theatre Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
Has anyone been experiencing this lately? On my 505, whenever I'm watching standard definition stations, every couple minutes the video goes to complete white noise static image. Sound remains on as normal. If I cycle the receivers power on and off quickly just with the remote, the video comes back. It does it again anywhere from 30 seconds to a few minutes later.

HD channels have no issue at all.


I've tried searching, but haven't seen anyone else reporting this. Any ideas?
 

·
Registered
Joined
·
104 Posts
I also have this issue with my 505. Even happens when i'm watching hd channel. Called *choice and they say that to keep a watch on it as the glitch will go away. It's been 2 weeks and still happening so i will give it another week before i ask for credit.
 

·
Registered
Joined
·
353 Posts
since audio and video are 2 separate things if you are going into the tv through the a/v cables which is what you should be using for good quality picture and sound. then there's the possiblity that the tv ( or maybe a surround receiver if you have one in between ) has something wrong inside.
does the screen appear to look like you're tuned into an antenna channel that nothing is broadcasting on ( nothing but snow ) or do you have lots of color like the image has been broken up like a jigsaw puzzle?
if you have a small tv you can hook up to the receiver and both tv's at the same time to see if it happens on both of them at the same time. if it only happens to the component video output or dvi output and not the composite video output or channel 3 output of the receiver, you can swap the connections on the tv's to determine whether it's your tv or the receiver that's at fault.
if both tv's do it no matter what inputs they use, i would suspect the receiver. if only the 1st tv is doing that i would suspect that the video selector in the tv is switching to the antenna tuner while the audio selector remains selected for the proper input. this is what i suspect is happening since a problem with the video output from the satellite receiver is more likely to result in a black screen or a scrambled looking colored picture instead of white snow.
 

·
Registered
Joined
·
4 Posts
Was watching HD Fox channel tonight and it happened about 10 times. When I swithched to SD Fox channel I had no problems.
 

·
Registered
Joined
·
5 Posts
New Firmware Issues

There is a problem using dvi to hdmi cables with the latest firmware (HDCP) on the 505. StarChoice has been using me as a test subject for this issue and the only solution so far has been to switch back to component's which resolves the snowy screen on SD channels. For whatever reason this glitch is not affecting my HD channels when running on HDMI cable. They are aware of the problem and are also aware of the fact that there are going to be alot of pissed off customers with expensive and useless HDMI cables that we should get credit for if they become redundant. I don't care what anybody says but my 1 year old Samsung plasma has a much nicer and crisper picture running off the HDMI in 1080i native / JustScan. Anyway's I'll try to keep an update to what StarChoice is doing to correct this.

Possible Causes
Your television set is not currently compatible with High-bandwidth Digital Content Protection (HDCP) or the DVI to HDMI feature on the Star Choice receiver.
Your television is not properly configured to receive a DVI or HDMI input.
Solutions
Ensure that your cables are properly connected and that "HDMI" is the selected input source on your High Definition television. You can commonly select this option using the options button on the remote included with your HDTV. If you are using a DVI to DVI connection cable, ensure that the on-screen input is set to "DVI".
Try using component video cables to connect your HDTV to your receiver. HD broadcasts retain the same superior quality picture using component video. Pick up your own set of Star Choice approved component cables at www.starchoice.com/accessories.
A future Star Choice software update is currently under development to include even further compatibility with more brands of High Definition television sets. Once released, this new software update will be announced via starchoice.com or receiver-based on-screen messaging.
Some televisions manufactured prior to the HDCP digital standard will no longer be compatible with this connection type. HDCP compatibility is included in all newly manufactured televisions. Please refer to your television user manual or the television manufacturer website to see if your television is HDCP compliant. If your television is not listed as HDCP compatible, you can still view all the best in HD programming using a component video cable.
If your Star Choice receiver is connected to your HDTV through a Home theatre system or digital repeater using an HDMI to DVI or DVI to DVI cable, you may also receive this HDCP error message. To correct this problem you can connect your Star Choice system directly to your television or use component video cables to connect to your Home Theatre or digital repeater system
 

·
Registered
Joined
·
373 Posts
"with expensive and useless HDMI"

Actually, it's the opposite. An HDMI cable is very cheap (<$10-15), while a good component cable is not. This is why I'm pissed off when someone tells me to go back to analog because digital fails.

Also, on my TV set, HDMI allows me to have no overscan at all while component does not, and rescans part of the 1080i signal into the 1080p matrix of my LCD screen, leading to a tiny bit blurier picture.

"my 1 year old Samsung plasma has a much nicer and crisper picture running off the HDMI in 1080i native / JustScan"

Completely agree with you.
 
1 - 6 of 6 Posts
Top