Canadian TV, Computing and Home Theatre Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
my rogers pvr keeps freezing when I turn it on .the tv and pvr sy tey are on but I get nothing on screen.the only way to clear this problem is to kill the power and then reboot.sometimes several times .rogers says its the pvr .I have replaced it twice already and it still happens .any ideas.
 

·
Super Moderator
Joined
·
56,436 Posts
@kenroy : I've moved your post to the Rogers forum from the Telus forum where you posted. What is the model number of your PVR (8642, 9865)? These sorts of issues are almost always related to a poor signal in your home or neighbourhhood. Call Rogers and have them check your signal. That's why swapping PVRs is almost never a solution. Here's an FAQ on the boxes and you can check the signal yourself:

https://www.digitalhome.ca/forum/30-57s-home-theatre-faqs/17719-57-faq-tips-sa-cisco-stbs-also-pace.html#post134376
 

·
Registered
Joined
·
8,656 Posts
1. Try reseating the HDMI cable.
2. Try changing the video resolution under settings. If it's at 1080p, try 1080i. If it's at 1080i, try 720p.
3. Try replacing the HDMI cable. It's not necessary to buy an expensive cable. Any decent quality name brand cable should work well. If you cannot find one locally, try Amazon. The "AmazonBasics High-Speed HDMI Cable" should be good enough. The "BlueRigger High Speed HDMI Cable" is a higher quality cable that isn't too expensive. The "Rankie HDMI Cable" looks like the best deal in a 6' cable and is highly rated.
 
1 - 4 of 4 Posts
Top