Canadian TV, Computing and Home Theatre Forums banner
1 - 2 of 2 Posts

· Registered
2 Posts
Discussion Starter · #1 ·
Hi there,

New to this forum although I've had a look around here a few times before and found some useful info. We have the Aliant Digital IPTV service in Halifax, Nova Scotia.

Before I get into the details, here's the main question:

Has anyone managed to get Lirc controlling the Aliant Motorola VIP1200 STB via infrared using an IR blaster, such as the USB-UIRT?

I've been building a Mythbuntu MythTV box and everything is running nicely and I bought the USB-UIRT to transmit channel change signals to the Aliant STB. After some fiddling, Lirc and the USB-UIRT are working together and I put the codes for our TV into lircd.conf which worked fine and changed the channels on the TV no problem. So, the software and hardware setup appears to work, but I just can't seem to get the right codes for the Aliant STB.

There's Lirc config files for the Motorola VIP 1200 in a few places but none of these are working for me. Also tried converting a ccf file, recording the raw remote codes, and a few other avenues, to no avail.

What does work is recording the raw codes from the remote using lrnhelper.exe in Windows. I could record a button press and that would transmit to the STB ok, so the problem seems to lie with the lirc config file and simply not having the right codes to transmit, I think.

Using the original Motorola_VIP_1200 config file as a starting point, and after some guesswork, I have managed to get some numbers transmitting successfully (except 6, 7 and 9) by adjusting the codes to:

0 0x00000000
1 0x00000001
2 0x00000002
3 0x00000003
4 0x00000004
5 0x00000005
6 0x00000006 # DOES NOT WORK
7 0x00000007 # DOES NOT WORK
8 0x00000008
9 0x00000009 # DOES NOT WORK

Note these codes only seem to work when using SEND_START rather than SEND_ONCE in irsend.

So I have 3 missing number codes that should, by all common sense, work just like all the other codes listed above.

For reference, here are the Motorola_VIP_1200 codes from the Lirc config file at sourceforge, which don't seem to do anything.

0 0x23402600
1 0x2340A601
2 0x23402602
3 0x2340A603
4 0x23402604
5 0x2340A605
6 0x2340A606
7 0x2340A607
8 0x23402608
9 0x2340A609

I thought they might be higher numbers, so I wrote a script to print out all the hex numbers from 0x00000000 to 0x0000FFFF and then a shell script to loop through the codes and see if any numbers came up, but no joy. Various other button codes came up, such as Menu, Guide and Power, but a few never appeared.

I'm stuck just three numbers away from having it all working smoothly! If anyone has had success controlling their Aliant STB using lirc then do let me know. I have heard about some success with other IR blasters such as the Hauppage, but I'd rather get it working with the USB-UIRT that I have already.

· Registered
2 Posts
Discussion Starter · #2 ·
SOLVED - using serial blaster from

SOLVED - Finally gave up on the USB-UIRT and ordered the simple serial IR transmitter from After a little fiddling with Lirc, it works fine with the standard Motorola_VIP_1200 config file. Yay!
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.