Canadian TV, Computing and Home Theatre Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
Hi, everyone, from a new guy.

The gear:

NAD T557 Blu-Ray player
NAD T747 AVR
Hooked up via Pearl HDMI cables, 3ft. from Blu-Ray to AVR, 6ft. from AVR to Samsung 6000 series 40in.

A while ago, we jumped into the world of LCD TV and Blu-Ray.

First off, no trouble with DVDs at all. Then, everything seemed fine, and I was pleasantly surprised to find that the T557 would play .mkv files off a USB drive (as well as .avi, .divx, .mp4 and a few others). Then I found that the audio (A_AC3 (ID2, type: audio)) in .mkv files that had Dolby Digital would sometimes not start when I ran the file. By cycling the power on the AVR or the Blu-Ray, the audio would start after one or two tries (or a half a dozen) With a couple of files on the USB stick, stopping one file and then starting another would not cause the audio to work. If it didn't function with one file, it wouldn't work on the other, until a reset was done on either unit. Once the files did work, they worked fine all the way through.

Then I tried my first Blu-Ray movie. The Bounty Hunter. (I know, I know). When it initalized, a funny little picture-in-picture frame appeared in the lower half of the menu screen (maybe some sort of video chapter selector), and then a warning panel appeared suggesting that my player might need a firmware update. I restarted the disk (the "mini screen" never appeared again), and managed to hit "Play", and the movie ran fine, it could be paused, fast forwarded, and rewound.

So, on the NAD support Web page I asked if maybe the BD needed an update. A support person named Pam Anderson's response to go and
ask the retailer was well, worrying. It was the support page, after all. I would suspect that a customer support agent would have access to
update status for the product line. Doesn't show NAD in a favorable light, but I digress. The Audio Centre did give me the e-mail address of someone from NAD (actually Lenbrook Industries) in Ontario to contact. He said that my unit was up to date.


Didn't watch many movies after that for a while, so it was only recently that I tried another Blu-Ray, this time "How to Train Your Dragon" (fun movie). All went well until the 1:23:00 point (approximately). Then, brief audio dropouts, a few seconds apart, culminating in silence, with the video working perfectly all through this.

I examined, and cleaned a fingerprint off of the edge of the disk. Problem recurred. The next day, I went to the video store and got a replacement, which I examined for fingerprints/dirt/cracks, and it was clean and unbroken.
The problem recurred at the same place, intermittent sound, then nothing. These problems seem to be associated with Dolby audio. When the .mkv files were running, the AVR displayed "Dolby Digital", and when the Blu-Ray movie was playing, it displayed "Dolby HD".

I contacted NAD, and found that my player had the latest firmware from last May.

Troubleshooting attempts:

The .mkv files ran perfectly with a USB drive plugged directly into the TV.

Both the .mkv files and "How to Train Your Dragon" ran perfectly if I connected the Blu-Ray player to the AVR directly via an HDMI cable.

The reason I put this into this forum, is that these symptoms, according to the NAD support engineer are more likely to be explained by the player possibly(!) needing a firmware update, because of the transmission protocols (HDCP, he said) through the AVR.

Ironic. One spends the money and follows the rules, and the experience is cr*p. Cheat and everything works fine.

Thanks for any ideas that would help me getting this thing working properly. I know, if it's the firmware and the DRM stuff, the only solution will be NAD fixing it.

Thanks for reading this screed.

Regards,

Bob M
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Solution

NAD has duplicated the problem and is developing a firmware patch.

Thread can be closed/deleted, or left for information.

Regards,

Bob
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Bad NAD lousy firmware problems

It's been thee firmware updates and it still doesn't work. If someone tries to sell you a NAD product, RUN AWAY!!!
 
1 - 3 of 3 Posts
Top