Canadian TV, Computing and Home Theatre Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
I am running pi-hole, though we have Actiontec R3000, not the HH. Also pihole is doing DNS only no DHCP - works fine for sure.

sunfiregt, what's the issue you're seeing? aka is HH not forwarding DHCP requests to Pi-hole? Or is DNS not resolving?
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #5 · (Edited)
I totally forgot to follow-up in this thread. I managed to get PiHole working with HH3000 with TV/phone/internet services.
Disable DHCP on the HH3000
Enable DHCP on PiHole
Add the HH3000 IP as a custom DNS
Check off an Upstream DNS provider
Leave DNS enabled on HH3000 (Obtain DNS information automatically)

11443



11444
 

·
Registered
Joined
·
6 Posts
habskilla, what other setting did you do on HH3K did you change the DNS automate to manual and pointed DNS to the pihole.. i did the following doesn't work for me
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #7 ·
habskilla, what other setting did you do on HH3K did you change the DNS automate to manual and pointed DNS to the pihole.. i did the following doesn't work for me
Leave DNS on HH3000 enabled
Also in pihole Settings / DNS / Upstream DNS Servers enable/check Google or whichever one you want
 

·
Registered
Joined
·
6 Posts
Leave DNS on HH3000 enabled
Also in pihole Settings / DNS / Upstream DNS Servers enable/check Google or whichever one you want
nope, sorry doesn't work

on PiHole:
DNS upstream enabled and
first server is point to 192.168.2.1

DHCP is enabled
Range of IP addresses to hand out
192.168.2.201 to 192.168.2.251
Gateway
192.168.2.1

on BELL:
DHCP is Disabled
DNS is Manually specify DNS information.

Primary DNS: 192.168.2.65
secondary DNS: 192.168.2.65

fyi: 192.168.2.65 is my pihole server

Also i have attached the debug report that i got from Pihole
 

Attachments

·
Registered
Joined
·
9,599 Posts
on PiHole:
DNS upstream enabled and
first server is point to 192.168.2.1
on BELL:
...
DNS is Manually specify DNS information.

Primary DNS: 192.168.2.65
secondary DNS: 192.168.2.65
Ok. It looks to me like the PiHole DNS is pointing to the HH3000 and the HH3000 is pointing to the PiHole. What could go wrong with that?

When I set it up, the PiHole pointed to an outside server. To find the fastest DNS servers take a look at DNSBench.
 

·
Registered
Joined
·
6 Posts
thank you for all the help...but i found a solution on another forum

this is what you do
reset the bell modem to default
keep bell dns as default
-disable DHCP on bell
-enable DHCP on PiHole
-under DNS
select google/cloudflare as upstream
save the changes and flush and release and renew ipconfig.
it is working for me now... not sure if it is permanent
 

·
Registered
Joined
·
9,599 Posts
Interesting. I chose to simply configure the pi-hole and point selected devices at it as required. Entire network use of the pi-hole was avoided because some sites don't work well (or at all) with ad blockers. It's also why I don't use a router based proxy service.

I also don't use ggl DNS. It's not the fastest or the best DNS server. Google already has too much personal data from other sources and adding a DNS trail and the privacy risk is compounded due to being based in the US where Canadians have no rights under US law. Everything else being equal, US based DNS services tend to have increased latency and lower reliability than Canadian based ones.
 

·
Registered
Joined
·
1,167 Posts
Discussion Starter · #14 ·
thank you for all the help...but i found a solution on another forum

this is what you do
reset the bell modem to default
keep bell dns as default
-disable DHCP on bell
-enable DHCP on PiHole
-under DNS
select google/cloudflare as upstream
save the changes and flush and release and renew ipconfig.
it is working for me now... not sure if it is permanent
Do you have phone service? And if so, is it still working?
thank you for all the help...but i found a solution on another forum

this is what you do
reset the bell modem to default
keep bell dns as default
-disable DHCP on bell
-enable DHCP on PiHole
-under DNS
select google/cloudflare as upstream
save the changes and flush and release and renew ipconfig.
it is working for me now... not sure if it is permanent
Do you have phone service? If so, is it still working?
 

·
Registered
Joined
·
6 Posts
habskilla, eveything is working fine... even though i don't use the service.. i didn't realized it was easy settings changes... spend weeks on it...now the problem remains is finding a good regex filter for youtube.com does anyone know of good one
 
1 - 15 of 15 Posts
Top