Canadian TV, Computing and Home Theatre Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
This is basic stuff but I'm new at this so forgive me in advance.

Here's what I'm trying to hook up: Sony XBR 9 TV + PS3 + Motorolla DSC530 HDPVR + HTS370 home theater system. I'm trying to run the PS3 and PVR through the receiver

Problem #1: The HTS370 won't pick up the signal from the PVR. There is a signal coming from the PVR because it works fine when hooked up direct to the TV. Is the DVI to HDMI a problem?

Problem #2. When the PS3 is hooked up through the HTS370 the quality is poor (sparkling blacks for example). It's not the cables because I've tried a variety I have on hand and they all work fine when hooked up direct to the TV. Is this a result of a cheap HTIB receiver?



Input appreciated.

Thanks
 

·
Super Moderator
Joined
·
56,506 Posts
1. You can't run the 530 through an AVR or HTiB via DVI-HDMI, as discussed in the following thread. Read post 1 and the link there. You'll have to connect the 530 directly to the TV and run optical (or other audio connection) to the HTiB from the PVR, or get a 630.

http://www.digitalhome.ca/forum/showthread.php?t=91028

2. It could be the HTiB. Does it even accept HDMI audio? If not, then connect the PS3 directly to the TV and use optical (or other audio connection) to the HTiB if possible. Here's an FAQ on AVR/HTiB features - see the part near the end on HD/HDMI audio as well as the other "features". You may wish to try setting the output of the PS3 to 1080i since some AVRs/HTiBs have difficulty with 1080P. What are the gauge and length of the HDMI cables you're using from the PS3 to the HTiB and from the HTiB to the TV? You may wish to consider a proper AVR with the appropriate features you need.

http://www.digitalhome.ca/forum/showthread.php?t=76082


Here's a post useful for those new to the forum - FAQs, Search Tips, Optimization, etc:

http://www.digitalhome.ca/forum/showthread.php?t=57741
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
1. Will a DCX3400 work instead of a 630? I want to run everything through the receiver so I can limit 1 cable to the TV. I could use a second PVR anyway.

2. Turns out I was wrong - switching to a shorter/higher quality HDMI cable has solved this problem. Not to start another cable debate, but when the receiver is hooked up with a Monster 960 vs a (albeit longer) no name cable, the sparkling blacks are gone...
 

·
Super Moderator
Joined
·
56,506 Posts
1. That's from a different service provider, but yes, it should work.

2. It's not the Mon$ter brand that fixed the issue, it's just that the gauge or quality of the other cable was poor. Plenty of us have purchased inexpensive, but good quality cables that work just fine. Here's a post on the topic and check out my previous third link too:

http://www.digitalhome.ca/forum/showthread.php?t=30452
 
1 - 4 of 4 Posts
Top