Canadian TV, Computing and Home Theatre Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Sorry not a electronics person so I'm going to come across pretty dumb here. Tryed search function also

I have a Toshiba 57" model 57HDX82. The original issue was a screen that looked like a poor antenna reception using Satellite, all snowy looking barely make out images on screen. Had a repair person fix that, then about a month after that I now have this issue.

The screen goes green and you can see people on the screen but just their outline faintly. It is mostly just a green screen on Sat or Video/DVD. It started out doing it occasionally about once a month now it is always green.

The guy worked on a board from the bottom right area of the TV last time when looking at TV from the back. He came back looked at it again thought it may be the same board and never heard from him again.

Thanks Michael M
 

·
Super Moderator
Joined
·
57,106 Posts
If you're connected via component video cables, unplug the cables, clean contacts/cables and replug them - your red cable may be poorly connected. HDMI, try similar method. See the following FAQ on Things to check.

http://www.digitalhome.ca/forum/showthread.php?t=19694

And the following post, useful for those new to the forum - FAQs, Search Tips, Optimization, etc:

http://www.digitalhome.ca/forum/showthread.php?t=57741

http://www.digitalhome.ca/forum/showthread.php?t=76085 Cables & Connections
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top