Canadian TV, Computing and Home Theatre Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
First post and hoping to get some help...
I have a sony kdlnx810 60" 3d tv that i bought about 2 weeks ago. I was laying in bed watching it tonight and the screen went totally blank and it made a "clicking" noise (This might have been the reciever). The set still had power with the idicator light being green and the sony symbol lit up. I powered on and off several times and the screen just stays black as if its shut off but each time the idindicator light comes on green and the sony symbol lights up just no picture.
I have an hd pvr, blu ray,xbox360 and ps3 all running via hdmi through a onkyo 270 reciever. I use the hdmi out on the reciever so i have 1 hdmi cable running to the tv. I dont think there is a problem with any signals or anything because when there is no signal, the screen is usually blue. I cannot get it to pull up any menus or the "home" screen. It is totally "dead".
I tried to unplug it and power cycle it but no luck.
Before i go back to where i bought it i thought i would check with you guys and see if you had any suggestions.
thanks for your help!
 

·
Registered
Joined
·
8,300 Posts
It sounds like it's failed to me. Electronic devices often suffer from "infant mortality", where something quickly fails. I think that's what happened to that TV.
 

·
Member #1
Joined
·
47,683 Posts
CHeck your manual. If nothing in the troubleshooting section describes your problem then a call to your retailer is in order.
 

·
Super Moderator
Joined
·
56,506 Posts
Here's a list of things to check.

http://www.digitalhome.ca/forum/showthread.php?t=19694

Does the user menu come up on the TV after you unplugged/replugged the TV - unplug it overnight tonight. Try connecting a device like the BD player or PS3 directly to the TV. If the user menu - options for picture mode, audio settings, etc. doesn't come up then the display/board may be shot.

Here's a post useful for those new to the forum - FAQs, Search Tips, Optimization, etc:

http://www.digitalhome.ca/forum/showthread.php?t=57741
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks for all the quick replies. No menus or anything will come up totally blank as if it is shut off... I took it back to visions and upgraded to the xbr900 60 inch. Had to pay a little extra but all in all walked away fairly happy.
thanks again
 
1 - 6 of 6 Posts
Top