Canadian TV, Computing and Home Theatre Forums banner
1 - 2 of 2 Posts

· Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
Hello folks, I have owned a Canon Elura 100 Video Camcorder for about 3 years now. It has been working great until recently when it keeps flashing a red X and a *Card Error* message on the screen whenever I turned it on.

This video camcorder can take pictures as well and it has a slot for SDHC memory card. Here is what I have done so far.

1. Remove the SDHC card and re-insert it (while the camcorder is off). Same error message.

2. Initialize the SDHC card as per instructions in the Canon manual. Same error message.

3. Put in another known working SDHC card (from my digital camera). Same error message.

4. Put the SDHC card from the camcorder into my digital camera and I could take pictures without any problem.

5. Ensure I do not have the wide screen mode on (as per another troubleshooting thread found via Google). Same error message.

Please advise on what I could/should do next. I used to be able to take pictures with this camcorder using the same card so I am not entirely sure why it would stop working now. The recording features are fine, i could still record to miniDV tapes without any problems.

Thank you.
 

· Registered
Joined
·
80 Posts
Discussion Starter · #3 ·
Thanks for the advice Bruce. I did call Canon tech support and was also given a quote of $149 + tax.

You are right, it's probably not worth it to pursue that option. It did come in handy 2 years ago when my old digital cam died on our cruise and I used this camcorder to take still pictures.

Oh well, it was good while it lasted.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top