Canadian TV, Computing and Home Theatre Forums

Canadian TV, Computing and Home Theatre Forums (
-   Home Theatre Personal Computer (HTPC) and Media Extenders (
-   -   Can't record any digital channels on Shaw via Firewire - help please. (

Mendel 2007-12-22 12:20 AM

Can't record any digital channels on Shaw via Firewire - help please.
I'm a Shaw Cable subscriber in the Coquitlam, BC area. I've been taking transport streams from my Motorola DCT6416 III DVR hard drive over to the computer with firewire, CapDVHS and the drivers/instruction at sourceforge, for about 18 months now.

A few things that have happened of late:

1. Maybe 4 months back, after a stretch without doing any recording, I found the computer no longer recognized the DVR, and I had to reinstall the drivers. I did so with the latest available.

2. About 2 weeks back, I started finding the transfer to the computer getting increasingly flakey, various problems:

a) out-of-sync audio (audio ahead of video by about 2 seconds) when converting the TS to DVD via SVCD2DVD

b) Transport stream capture getting increasingly problematic and failure prone.

Today I've tried various captures seeing what can and can't be done. As far as I can tell, the *only* thing I can record now is Shaw Cable's channels 1 through 58. They record just fine. Channel 60 and up, is now impossible to record with CapDVHS. Live capture in particular never works.

CapDVHS shows no statistics during recording, but outputs a ts file. Media Player Classic says it cannot render the file, and sometimes locks. Capture from playback of DVR recordings will sometimes show statistics when recording via CapDVHS, but playing the resultant ts file via MPC it will either just show black (while the play progress bar moves left to right), or will play a few seconds and then lock, or show what appears to be audio only, the window minimizes as if there is no image, just audio.

Things I've tried:

a) Boot the DVR via unplug/replug while pressing both 'power' and 'menu'.

b) Removing/inspecting/reversing the firewire cable. It's a 25 footer, which may be an issue, but the lower channels are still recording, and it seems ok.

Any ideas greatly appreciated, thanks in advance.

57 2007-12-22 12:53 AM

Have you checked the 5C settings on the channels that you've been trying to record? Shaw has been encountering lots of issues lately and perhaps these settings got changed? (For example, the encryption for digital channels is currently not working properly.) Here are a few threads that may help? Shaw 5C Recording HD

Could it also be a signal strength issue to the STB? You can check the S/N Ratio, etc in the diagnostics.

I_Want_My_HDTV 2007-12-22 01:06 AM

It could also be a firewire port issue on the PC or some other PC issue. 25' is a bit long for the firewire cable too. (Could affect higher data rates.) I've seen similar issues but don't use Shaw so I can't comment on their service or receivers.

Mendel 2007-12-22 12:35 PM

Thanks all for the links and suggestions, I'll continue to trouble shoot. The high def movie channel (for instance) shows:



It could be a combo of the 25' firewire cable coupled with a reduction in signal strength from the provider. Perhaps I need a repeater?

I had a splitter for the fm tuner, I've tried removing that, but no change. All the cables/splitter/connections look to be high quality, installed by the shaw rep.

So, I have no problems with channels 1 thru 58. Channel 60 and upward (there is no channel 59) are not being captured by CapDVHS, or almost never. Live: never. Via playback from the DVR's hard drive: usually still nothing, occasionally a few seconds, then lock up.

Channel 60 is not the start of high def channels. It is tho the first channel that you can't receive without the extra set-top box.

Mendel 2007-12-23 10:16 PM

To update: I unplugged everything, took the dvr over to the computer and hooked it up via an alternate six foot firewire cable. There's no difference. Non-digital channels record with CapDVHS, no problems, digital channels do not record.

This is in the Coquitlam, BC area, with Shaw. Anyone else in the area having simliar problems, or could please check this out?

Also, anyone hazard a guess as to how approachable Shaw is on this issue?

57 2007-12-23 11:25 PM

I thought I read in the "free digital TV" thread on Shaw that many/all of the channels now have 5C=1.

Mendel 2007-12-24 01:12 AM

These statistics:



Show for all of the following:

Channel 3 CBUT (Vancouver CBC, analog channel) <CapDVHS recording ok

Channel 60 MC1 (Movie Channel 1, low-def digital) <CapDVHS not recording

Channel 211 MCHD (High Def Movie Channel 1, high-def digital) <CapDVHS not recording

Maybe there's something else differentiating them. I've read of "flag". Is this separate from the 5C designation?

For now the one common denominator I've found is that the problem is with all 'digital' channels.

Current firmware version of my DCT6416 III is: 16.41

Still stumped :confused: I'll have a read through the link.

57 2007-12-24 01:22 AM

There is a flag, however, it has not been implemented since it was ruled illegal - as discussed in the Recording HD FAQ previously given in post 2.

Are you looking in the correct place for the 5C designation in the STB? I believe it should say 0 or 1, not "no", as you indicated.

There is also CGMS-a, which affects analogue signals, discussed in the following thread, however, that should not affect a digital (firewire) connection, although, I have heard of recent movies having CGMS-a, but it sounds like you have difficulty with all digital channels, not just specific programmes.

I'm very surprised that no one else recording via firewire on Shaw has commented in this thread, or, if the problem exists Shaw-wide, posted on the issue. I'll change the title of the thread to see if we can get some help.

flimpy 2007-12-24 12:16 PM

Edmonton, Alberta

I have the exact same problem. I have been (successfully) recording firewire programs to my PC based DVR for several years. Suddenly, as of a few days ago... nothing. It is hard to say exactly when it stopped working becasue I have a backlog of recordings, but it was within the last two or three days.

I can record the basic channels fine. I cannot record the high definition channels, or any of the digitial channels, AT ALL.

I had installed Vista SP1 and was thinking that might have been the problem, but now that someone else is having the problem, I don't see that as likely (especially since recording of basic channels works).

This is... frustrating. I refuse to buy the HD PVR from Shaw (because it sucks). I don't want to have to go back to not having any high definition programming at all, though. Tricky.

flimpy 2007-12-24 12:22 PM

Odd, I posted a reply to this but it hasn't appeared.

Anyway, I'm having the same problem in Edmonton, Alberta. I checked the dignostics page (by powering the box off, then pressing menu twice, then pressing select, then selecting d11, and then going to page 3) for the 5C status and it says that it is "not implemented". That is the only place I know of to check the 5c status.

Recordings of basic cable work fine; recordings of digital cable or HD material do not work, at all.

I thought it might be Vista SP1, but that doesn't seem likely since someone else is having this problem right at the same time. That would stretch the bounds of belieavability.

57 2007-12-24 12:24 PM


Odd, I posted a reply to this but it hasn't appeared.
For some reason the post was put under moderation - it then needs to be approved by a mod. I have (obviously) approved the post. This sometimes happens for newbies as mentioned in your forum sign up information.

Mendel 2007-12-24 02:23 PM

Flimpy, good (and not good) to hear someone else is experiencing the same problem. BTW, are all the digital channels unlocked for viewing just now, in your area, regardless of what you've purchased? They are in our area, Coquitlam BC. This is the subject of the last link from 57. Perhaps there's a connection to the digital channel recording problem?

57, I was wondering about 5C being indicated as "NO" (not "0") as well. I found that setting at the same location as Flimpy describes, and if he is being literal, his setting "not implemented" is different as well. Due to different makes and firmware?

I have recordings stacked up on the dvr, recorded (semi-successfully) over the last few weeks, but I'm more or less resigned to them being toast. I can record ts's of them, and these seem fine, but conversion to video dvd invariably has audio sync problems. On the conversions the video always "stalls" for a few seconds at the very beginning, and the audio gets ahead. Also, If I load these ts's into something like HDTVtoMPEG2, they don't play properly.

I suspect something has been deteriorating, prior to this complete inability to record digital channels. It's my hope that something is temporarily broken, and will get fixed.

flimpy 2007-12-24 03:03 PM


I'm not sure about the digital channels being locked/unlocked. I don't actually have a TV hooked up to the box, so I don't have an easy way to check (well, now that recording doesn't work anyway).

As for the 5C, I was going from memory. I believe it said "5C Implementation: No". The line below it listed the status as "copy free".

Mendel 2007-12-24 05:13 PM

Mine as well says "copy free" on next line. Very telling: both digital and non-digital stations all have the same settings. There must be some other factor, methinks :confused:

zoltar 2007-12-25 02:11 AM

Same here in Calgary. Used to be able to record all channels (including HD) over firewire, no problem. I still get a few HD channels (218, 219, 220, 221) but no others and no movie central (55, 56, 57, 58) either. Very annoying. Called support but everyone who knows anything is out on holiday. I'm THIS close to canning my cable subscription and downloading everything from BT or something.

All times are GMT -4. The time now is 03:32 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

For the best viewing experience please update your browser to Google Chrome