Canadian TV, Computing and Home Theatre Forums - Reply to Topic
Thread: 9241 Internal hard drive replacement Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
2019-04-13 06:07 AM
Allan B If you are just putting the troublesome drive in to format, I don't really see a problem...
2019-04-11 07:36 PM
Justpassingtime I thought of that but didn't want to touch the other system as it is working fine and I just changed the caps and hard drive on that one about a month ago. Didn't want to jinx that one!
2019-04-11 09:13 AM
Allan B Silly idea number 42, could you format it in the other 9241, then swap it across?
2019-04-11 12:10 AM
Justpassingtime Sorry I was making a correction to a typo in my previous post. I know it should format on its own but it isn't for some reason.
2019-04-10 09:14 PM
calltrex
Quote:
Originally Posted by Justpassingtime View Post
that should have said it won't format on its own
Yes it does

Sent from my SM-G965W using Tapatalk
2019-04-10 09:00 PM
Justpassingtime that should have said it won't format on its own
2019-04-10 08:58 PM
Justpassingtime
Can't get hard drive to format

I am stumped with a problem I am having with another one of my 9241 receivers. The hard drive went on it and I ordered a replacement on EBay. While I had the case open I changed a few of the caps that were bulging and the rest of the known problem ones also that weren’t showing signs of bulging yet just to be proactive. I have cleared the NVRam according to suggestions and installed the replacement hard drive. I won’t format the drive on its own and when I go to the memory dump screen and press Play, Play, return (the config dump screen pops up even before I get to press Return) I get the message that the hard drive is being cleaned and not to disturb the process and it will reboot upon completion. The system does reboot 3 times with that same hard drive is being cleaned screen appearing for two of the boots. On the third boot it goes to the 311 error screen about hard drive error. I have tried going back into the memory dump screen and doing the short HD test by pressing Pause, 1. It completed the test and all smart results passed. I also tested the drive attached to a PC and it passed all tests. I created a partition and then wiped the drive. But still no luck getting the 9241 to format it. Not sure why it can see the drive, clean it, pass the HD test but I can’t get it to format. Any suggestions would be appreciated.
2019-03-20 11:44 AM
Werwer
1 tb internal replacement drive for 9241

Does someone knows the 1tb drive models that will fit into a 9241?

Thanksssssssss!!!
2019-03-10 03:50 AM
Justpassingtime M3repair that worked! I thank you so much. I didn't realize that when I saw the non-volatile memory has been corrupted message that the replacement hard drive had to be connected after unplugging the power. I thought I needed to see NVRam cleared before doing this.
2019-03-09 08:20 PM
m3repair you did clear the nvram when you did that and it says non-volatile memory has been corrupted. when you are told to unplug it is at this time that you put your new hard drive in and then plug the power back in and let the 9241 do its thing and will figure out the new hard disk own its own (mind you im certain you are matching the new drive to ensure it is compatible in the list of approved drives)
2019-03-09 02:04 AM
Justpassingtime
Can't clear NVRam

Hello,

I was wondering if anyone has any suggestions. I'm trying to clear the NVRam according to the procedure that has been posted several times in this thread but keep getting the "non volatile memory is corrupted..." message and unplugging or using the reset button on the front doesn't help. I have tried doing multiple resets, have replaced caps on the board, unplugged overnight, etc. I have full live tv just can't clear the NVRam to be able to swap out the failed hard drive. (Can get the tv function only when drive is unplugged from the main board).
2019-01-11 08:05 PM
FasterHarder
Quote:
Originally Posted by m3repair View Post
@calltrex you need to clear the nvram before installing the NEW Hard disk, as this will force the receiver to format the disk all by itself normally. Sometimes you may need to leave it connected to a satellite feed overnight for the hard disk to marry to the satellite receiver
Yes this is what I did and it worked flawlessly. I replace my HD in my 9241 with Seagate 500GB ST3500312CS 5900RPM 3.5" SATA Hard Drive for about $45 from Ebay. This is what I did before replacing the HD. I dumped the NVRAM as discussed in this thread by doing this.

Accessing the memory dump screen:
Press Menu, 6 (System Setup), 3 (Diagnostics).
Within 5 seconds press Info, Browse, Theme.

Clear NVRAM:
<<You should be at the Memory Dump screen.>>
Press TV/Video.
A different screen will pop up telling you that you have erased the NVram.
Then just press the power button on the receiver.
You will lose all favorites, timers and customized settings.

I then replaced the HD and the receiver booted up a couple times found the hard drive and formatted it automatically, then rebooted again.

As I lost the remote control function at this point I had to use the buttons on the front of the receiver by pressing "Menu" then getting to "System Setup" then selecting "Installation" then selecting "System Info". In box "i" you will see "Rem Addr" and it was showing "1". I then used the remote control and pressed the "sat" button until all buttons on the top lit up red and then sat button starting flashing green. Within 5 seconds I pressed the "record" button 3 times on the remote control and the "Rem Addr" changed to number "4". Mine did and all was working after that.

Check out the new replaced HD and it works great!

Hope this may help anyone else dealing this issue. Thanks for the many threads people have contributed before to help me fix my 9241 receiver!!!
2018-11-29 07:41 PM
m3repair @calltrex you need to clear the nvram before installing the NEW Hard disk, as this will force the receiver to format the disk all by itself normally. Sometimes you may need to leave it connected to a satellite feed overnight for the hard disk to marry to the satellite receiver
2018-11-27 03:05 PM
calltrex
Quote:
Originally Posted by jdevlin View Post
Trying test a new hdd in my 9241. I can't find the info about how to format the drive.
Does it by it self

Sent from my SM-G965W using Tapatalk
2018-11-27 02:51 PM
jdevlin Trying test a new hdd in my 9241. I can't find the info about how to format the drive.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome