Canadian TV, Computing and Home Theatre Forums - Reply to Topic
Thread: Upgraded internal HDD for the 630 Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
2019-08-22 05:20 AM
QCK Thanks to Rob T for the message above, and some personal advice, I was able to do an hard drive install as well with a "Samsung SSD 860 EVO 1TB 2.5 Inch SATA III Internal SSD (MZ-76E1T0B/AM)" hard drive. My 630 is much faster in response, acting like a brand new updated receiver.
2019-08-09 01:29 PM
rob_t OK, so I bought a used 630 and got it activated (I wanted a second one anyway). It's nice to be able to record stuff again. I'd still like to get the old one back on the air myself with a bigger drive if I can.

So I thought I would use the eSATA case and my existing 1Tb drives to see if this box would work with an external drive. With the power off on the eSATA case, I put the hard drive in, plug the cable into the 630, and then power up the eSATA case. And nothing happened. What I had to do was to unplug the 630 and let it reboot with the eSATA enclosure powered on. With both drives, I got an offer to format them, and did that. I took the Samsung SSD and put it in the dead 630, and it accepted the drive and is a PVR again! :-)

So it looks like the 56.05 firmware is no longer able to format drives without a working drive in place, but its good news that you can do this on another 630. I am happy :-)

Thanks,
Rob T
2019-07-28 10:29 PM
ExDilbert I've always check the NAND used by the SSD drive maker. There will always be lower quality, lower priced products. I'm not saying you should purchase them. I've seen a few early model SSD drives fail. They failed suddenly with no chance to recover any data. Newer SSD drives from quality makers are much better, some have a better life expectancy than comparable hard drives.

The quest for higher capacities has taken it's toll on hard drives as well. I've seen a greater than 50% failure rate on a dozen drives of one model in the first three years. That compares with no failures on earlier drives of the same make with lower capacities. WD's response was to shorten the warranty from 3 to 2 years so they wouldn't have to replace them. They've kept failing well under the expected lifespan ever since.
2019-07-28 01:54 PM
RuralRouter
SSD

From the article QUOTE: Newer isnít always better. Recently, SSD manufacturers have begun to trade off speed and reliability in the interest of cramming more storage space into their drives. Protocols like NVMe and PCIe are getting faster, but some SSDs are going backward. UNQUOTE


https://www.howtogeek.com/428869/ssd...-to-qlc-flash/
2019-07-28 12:37 PM
ExDilbert The days when SSDs would rapidly wear out are gone. Modern SSDs will last as long as most convention hard drives (longer than some brands on the market) and are being used in high demand scenarios such as internet cloud storage and file servers. The main issues with SSDs are cost and capacity and even those are rapidly disappearing. Another is SSD support in certain devices such as PVRs. Many PVRs are based on dated software and designs that don't support SSDs well.
2019-07-28 09:23 AM
OlStatic I think the SSD life would still outstrip that of the machine itself.
The issue that I see is the lack of trim commands and would be a problem with a dvr that writes and reads all the time.
2019-07-28 01:40 AM
Bell_MTS User Don't use an SSD on a PVR. unless you want to change then on a regular basis. A PVR will chew them up and spit them out. PVR's write and delete everything you watch even if your not recording the show. SSD's can only handle so much write/deletes before they die out.
2019-07-27 11:25 PM
ExDilbert Something seems to be going on. Have you tried replacing the SATA cable? It's possible that Shaw is locking down the usable hard drives in firmware. Bell PVRs have always been that way. It's also possible that he reformat procedure has been changed in firmware. Got to wonder if a drive out of another 630 would work or if the 1TB drive works in another 630. That would determine if the 630 is faulty.
2019-07-27 10:37 AM
rob_t I did a factory reset with the WD Blue drive, and my results were no better - no offer to format, and still seeing "no hard drive found". I put a GPT partition table on the SSD and put a FAT filesystem on it, and Diag R still shows a zero for size, and the factory reset still shows "no hard drive found". I think this is just not going to work. I'm going to have to try to get this unit replaced, and give up on upgrading my HD size for now. Sigh.

Rob T
2019-07-27 12:00 AM
ExDilbert I would try a FAT32 filesystem. Other possibilities are no filesystem or GPT instead of MBR. NTFS is not native to Linux (though often supported) so that may be messing it up.
2019-07-26 10:01 PM
rob_t
Does this look bad to anyone else?

So ... I noticed something that might be an important clue.

If I do Options-6-4-9-7-7-1 and go to Disk diagnostics, the unit now knows what model and serial number the drive is, but thinks it has zero bytes. I would expect the drive size to be reported correctly.

If I do Options-6-4-9-8-8-6 to go to the Factory Reset menu, it reports :"PVR hard drive content" - "No Hard Drive Found". I would expect from reading the 530 drive upgrade thread that I would have a choice to erase the hard drive, and I do not. Is the 630 different here? Or does a format happen after a hit?

Are the things I observe above normal? I wonder if there is something else that's wrong.

The original 320Gb disk is truly scrogged - neither a Windows box nor my Mac can identify it if it is attached via an external case.

I did reformat my Samsung SSD with a FAT32 filesystem to see if it mattered; I could see the drive ID in Diag R but it showed up as 0 bytes, and nothing happened after a Factory Reset and a "hit". I had to wait some time between the reset and the hit - SD's website was not cooperating for awhile.

I have reformatted my WD Blue drive and may try this again with it when I can issue another hit. But I wanted to describe what I'm seeing.

Rob T
2019-07-25 08:20 PM
rob_t So I got my WD Blue WD10SPZX, formatted it with a MBR partition table, did get a factory reset done (thanks, @k801809 ), and sent an online "Refresh TV Receiver" request. From showing CPAC on 291 and not knowing other channels, I see my classic channel lineup and can tune to them, so I know the "hit" worked. But I didn't get an offer to format the hard drive. I got the "no HD found" error before I sent the hit - do I need to be faster with the hit?

What causes the HD to be reformatted, and what does that look like?

Also wondering if I should lay down an MS-DOS FAT32 filesystem on the HD. Might try that in the morning.

Rob T
2019-07-25 01:14 PM
k801809 The remote shortcut to factory reset is OPTIONS, 4, 9, 8, 8, 6. That should work every time!
2019-07-25 12:26 PM
rob_t Thanks guys - I did format my Samsung SSD with the "Computer Management" -> "Storage" -> "Disk Management" snap-in on a Windows 7 box before dropping it into the 630. It was a virgin drive at that point. I think I created an MBR-style partition table as opposed to a GPT-style partition table, and I think I created an NTFS volume in a single partition. If that sounds like the wrong choice to anyone, I'm all ears.

I have a new WD Blue WD10SPZX coming today.

Still asking: is there a trick to the Options-4-9-8-8 step (seems extraordinarily tough to hit), and when does the HD format happen?

Rob T
2019-07-24 02:57 PM
ExDilbert It's probably a good idea to freshly format the drive with a single Windows partition, not sure if it's required. Formatting will ensure that a drive signature and partition table exist. If the drive has been wiped or never been formatted they may be missing and may be required. The HDPVR 630, like most PVRs, uses multiple Linux partitions so it doesn't use the Windows partition that exists an many new drives. Checking the drive with an extended SMART routine might be a good idea as well, especially if the drive has been in use for some time.
This thread has more than 15 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome