SiriusXM Free Previews - Canadian TV, Computing and Home Theatre Forums
 12Likes
Reply
 
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 63 (permalink) Old 2014-08-23, 06:07 PM Thread Starter
 
Join Date: Apr 2012
Location: Nova Scotia
Posts: 728
SiriusXM Free Previews

Another free preview is scheduled for August 26th until September 8th.

http://www.siriusxm.com/sxmlp314?sxmlpId=listen5

60 channels FREE for 2 weeks.
NovaMan is offline  
Sponsored Links
Advertisement
 
post #2 of 63 (permalink) Old 2014-08-24, 09:14 AM
Veteran
 
Join Date: Mar 2006
Posts: 4,544
nice, im going to dust off the Sirius XM radio on tuesday and listen in.
17671 is offline  
post #3 of 63 (permalink) Old 2014-08-26, 10:12 AM Thread Starter
 
Join Date: Apr 2012
Location: Nova Scotia
Posts: 728
Quote:
Originally Posted by Paolo View Post
nice, im going to dust off the Sirius XM radio on tuesday and listen in.
Yes, I'll dust off the second one that I keep in the garage.. Might get some chores done out there this week. :-)
NovaMan is offline  
 
post #4 of 63 (permalink) Old 2014-08-26, 12:11 PM
Veteran
 
Join Date: Jun 2007
Location: /dev/null
Posts: 3,022
I wonder if the looping content is changed since the last preview
99semaj is offline  
post #5 of 63 (permalink) Old 2014-08-26, 09:19 PM
Veteran
 
Join Date: Nov 2003
Location: Airdrie, AB
Posts: 4,260
Couldn't get my radio in my car to get on the free preview. Keeps saying that I need to subscribe. Is it working for anyone today?
MarcP is offline  
post #6 of 63 (permalink) Old 2014-08-26, 11:04 PM
 
Join Date: Aug 2005
Location: East St. Paul, MB
Posts: 163
Yes working just fine for me. Prior to cancelling the service some time ago, I could set channels on XM1, 2 or 3. But today can only select channels on XM1.
Works for me - free is free!
HTGuy2 is offline  
post #7 of 63 (permalink) Old 2014-08-27, 03:20 PM Thread Starter
 
Join Date: Apr 2012
Location: Nova Scotia
Posts: 728
Quote:
Originally Posted by MarcP View Post
Couldn't get my radio in my car to get on the free preview. Keeps saying that I need to subscribe. Is it working for anyone today?
Working on my second radio in the garage, but it took about 30 minutes for it to come in.
NovaMan is offline  
post #8 of 63 (permalink) Old 2014-08-27, 11:14 PM
Veteran
 
Join Date: Nov 2003
Location: Airdrie, AB
Posts: 4,260
It's working for me as well now. They didn't turn on the channels I used to like (Hair Nation, Octane, etc). Those don't seem to be part of the free-view. Oh well...
MarcP is offline  
post #9 of 63 (permalink) Old 2014-09-09, 08:10 PM
 
Join Date: Sep 2011
Location: Quebec
Posts: 275
I was expecting it to de-activate today since it was supposed to end on Sept. 8th.However it was working today to and from work.Maybe they forgot to de-active mine.LOL
Voodoocobra is offline  
post #10 of 63 (permalink) Old 2014-09-10, 11:33 PM
 
Join Date: Oct 2010
Posts: 36
They get done in batches,

Your radio needs to be on when they send the activation/deactivation signal. Same reason it needs to be on for a bit to start working.

I picked up a used radio, for the amount I used it, was working almost a year before it got the deactivation
kevinds is offline  
post #11 of 63 (permalink) Old 2014-09-11, 05:29 PM
 
Join Date: Feb 2009
Location: Winnipeg, MB
Posts: 757
I have an old unit that I tried using after I cancelled years ago. I waited 3 months like someone told me, turned it on, and sure enough it worked. Not for long, maybe a couple weeks? I forget. I tried it a couple months ago again, and no dice. Will give it a try again soon.

I have a 2014 GM vehicle and let my free 3 months lapse. I had a problem with the electronics for a short time, where the backup camera stuck on. It cleared up, but after that, the SiriusXM started working again! It went in for repair, and they did an update on the radio system, and the SiriusXM stopped again. Oh well, not a big deal to me.

Authorized Service Provider (Contractor) for MTS Allstream. Any views expressed are my own.
Macman is offline  
post #12 of 63 (permalink) Old 2014-09-11, 06:44 PM
 
Join Date: Oct 2002
Location: NOYB
Posts: 124
I bought a 2008 Ford Fusion 2 years ago, and it's still working. I get the feeling the previous owner may have purchased one of those lifetime subs.
frostycold is offline  
post #13 of 63 (permalink) Old 2014-09-11, 07:52 PM
 
Join Date: Sep 2011
Location: Quebec
Posts: 275
Yeah your right,worked all week but today it died.Was left with the free preview station which by the way is OK.Its better then listening to that boring French music.
Voodoocobra is offline  
post #14 of 63 (permalink) Old 2014-09-12, 12:54 AM
Veteran
 
Join Date: Nov 2003
Location: Airdrie, AB
Posts: 4,260
I had an old Starmate unit that I took offline for 6 months after deactivating, but it never got the kill code. When I put that Starmate back in action, it worked for 4 years with no problems until it physically started to die. The screen would go off and back on, sometimes the unit would never come on then come to life magically... Until it fully died. I miss that Starmate.
MarcP is offline  
post #15 of 63 (permalink) Old 2014-09-12, 12:14 PM
 
Join Date: May 2011
Location: Longueuil
Posts: 832
If you had a Starmate, your problem was most likely (read with 99.9% certainty) caused by a loose power adapter which is ssssoo easy to fix. So if you can find it, consider opening that cheap plastic enclosure and practice a bit of soldering on the black power receptacle.

Going nowhere @ 220 ft
John Koenig is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome