2 routers one with vpn and one w/o - Canadian TV, Computing and Home Theatre Forums
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 13 (permalink) Old 2013-01-15, 10:40 PM Thread Starter
Join Date: Jan 2013
Posts: 9
2 routers one with vpn and one w/o

Hi there,

I recently signed up with voip.ms and I'm using the OBI100 as my ATA and was working great until I signed up with UnoTelly to use the DNS and VPN services.

When I had the OBI100 linked in through my TP-Link router and the DNS or VPN service I was having issues with the my voip.ms registering. After doing a little research I now realize that voip.ms doesn't work well with if a DSN service is being used so I reverted back to my original setup and everything returned back to normal. However, the next day when I went to work and talked to someone about this they told me I could alter my setup and use two routers (one to use the VPN/DNS) and one to use strictly for voip.ms. I also had a Linksys router on hand I thought I might give it a try.

His suggestions was to hook up the modem to the Linksys (router 1) and then connect the OBI100 to it. Then I could connect the TP-Link (router 2) to the Linksys which I would then configure the TP-Link router to access DNS servers provided by Unotelly. So I setup my devices in that order and turned on the DNS through the TP-Link router. I checked my voip.ms account and saw that the main account was still registered.

Now, when I make calls from my Voip phone to my cell phone the numbers appears with the "011" or "011 001" prefix ahead of my DID #. And when I make calls to my DID using the number assigned to my main account I get sent directly to voicemail with the setup greeting. I've checked to make sure the account setting are correct in voip.ms and on the obitalk website and everything looks alright on the surface(however I could be overlooking something). Once I turn the DNS service off and log out of the account after a couple minutes the phone number appears as it should when I call my cell but I'm still unable to make receive inbound calls to the voip phone.

Anyways what I'm looking for is how can I set up my voip.ms account on one router and my vpn/dns on another router? Am I going about this all wrong or is there another way to get the same results?
dragonfyre77 is offline  
Sponsored Links
post #2 of 13 (permalink) Old 2013-01-16, 10:41 AM
Join Date: Jun 2008
Location: Whitby, Ontario
Posts: 372
I'm not sure what you're using the VPN for, but Unotelly's DNS proxy is typically used for accessing content in Geo-blocked regions.

If that is the case, I'd simply use the DNS service on the specific devices you intend to use it on, rather than the entire network.

For example, I use my ISP's DNS on the router, and use Unotelly's DNS servers on my TV. This way, I access the U.S. based Netflix without impeding anything else.

The problem with setting another providers' DNS settings on your router is that it bypasses CDN networks that have been setup in each region. Basically, you'll notice browsing speed is quick, however downloads may be slow as it's using the CDN from wherever your DNS is making you appear from. This is how it was explained to me, once upon a time.

I would only use Unotelly's DNS service on the device you specifically intend to use it's purpose for, not the entire LAN. As well, it will also have no effect on your VoIP service.
cambo is offline  
post #3 of 13 (permalink) Old 2013-01-16, 11:52 AM Thread Starter
Join Date: Jan 2013
Posts: 9
Thanks for the advice cambo and I'm open to that idea however there are two issues that I have going this route.

1. The Boxee Box doesn't allow me to change the DNS to UnoDNS and just gives back a message saying some thing to the effect that the settings weren't saved. This is the reason I think I need one to for the DNS and VPN so that I can download and have access to foreign content.

2. My voip.ms phone will not work when the DNS service is activated. Therefore I think I need one that doesn't utilize the DNS or VPN services for the phone to work properly.

These are the two main reasons I am trying to setup the two routers. However, if there is another solution then I'm open to giving it a try.
dragonfyre77 is offline  
post #4 of 13 (permalink) Old 2013-01-16, 12:01 PM
Join Date: Jun 2008
Location: Whitby, Ontario
Posts: 372
Have you tried following this guide?

cambo is offline  
post #5 of 13 (permalink) Old 2013-01-16, 12:17 PM
Join Date: Jun 2011
Location: 43° N, 81.2° W
Posts: 8,509
Here are some basic instructions for setting up the second router.Connect the WAN port to one of the LAN ports on the first router.
  • Set a static address for the second router on the same subnet as the first. Something like 192.168.x.5. Just make sure it is not in use anywhere else.
  • Disable NAT and DHCP on the second router and enable DHCP forwarding.
  • Set up the proxy on the second router as instructed.
Depending on the routers and services, there may be some further tweaking required. If it doesn't work as required, disabling the firewall on the second router is a possibility.
ExDilbert is offline  
post #6 of 13 (permalink) Old 2013-01-16, 08:41 PM Thread Starter
Join Date: Jan 2013
Posts: 9
Cambo - yes I've used that guide and haven't had any luck. I have had more success by going into the router and changing the settings their.

ExDilbert - thanks for the advice I'll give it a shot when I have a chance tomorrow. Just a question though regarding disabling the NAT; after doing some reading, will disabling that result in no access to the internet. If so how will I be able to access the internet to utilize the vpn or dns services. Not sure how all that works.
dragonfyre77 is offline  
post #7 of 13 (permalink) Old 2013-01-17, 01:02 AM
Join Date: Jun 2011
Location: 43° N, 81.2° W
Posts: 8,509
NAT just provides the one external to many internal address translation. It has nothing to do with VPN but it's not a good idea to have two NAT translations. The first router will still be doing this so the second doesn't need to. The same thing goes for DHCP. True VPN does not depend on local network information to work. It creates a direct, virtual connection to the remote VPN server over the existing infrastructure. That can be done on the local PC or in a router. During the setup, you will probably need to point the local system at the second router for router VPN to work properly. Like I said, follow the VPN setup instructions. It's probably best to get the second router working as a regular router/access point first and then do the VPN setup. Then check the connection to make sure VPN is working properly.
ExDilbert is offline  
post #8 of 13 (permalink) Old 2013-01-19, 12:49 PM
Join Date: Oct 2004
Location: Winnipeg
Posts: 240
Can't you just set the DNS you want on the OBI100 ?
It has settings to allow that. Then your other devices will use the Unotelly DNS and your VOIP will use the one you want.
vango44 is offline  
post #9 of 13 (permalink) Old 2013-01-19, 11:51 PM Thread Starter
Join Date: Jan 2013
Posts: 9
ExDilbert, I've followed the instructions that you provided above up to the point where you recommend enabling DHCP forwarding. I'm not completely sure what you mean by this. In my TP-Link admin page I can see for options under Forwarding (Virtual Servers, Port Triggering, DMZ and UPnP). After doing some research I wasn't able to find anything conclusive about which options to adjust but I figure its either the Port Triggering or DMZ, however in each screen it also says to ensure the NAT is enabled for the configuration to take effect.

Additionally, should I be pointing the gateway through the ip of the first router or just leave it blank?
dragonfyre77 is offline  
post #10 of 13 (permalink) Old 2013-01-19, 11:52 PM Thread Starter
Join Date: Jan 2013
Posts: 9
Vango44, I'm not sure I completely understand what you are saying. Could you explain a little further? In the scenario that you are describing would I need to have two routers or could I point the obi to a different dns through one router. Also when I have the UnoDNS on will it "communicate" with the OBi100. One of the problems I'm having is that my voip.ms account will not operate while going through a DNS/VPN. Thus if it communicates with the OBi then I'm not sure it will work.
dragonfyre77 is offline  
post #11 of 13 (permalink) Old 2013-01-20, 01:30 AM
Join Date: Mar 2006
Location: Calgary - Shaw phone/internet, OTA attic / Pigeon Lake - CCI Wireless, VoIP.ms, OTA, FTA, LTSS
Posts: 810

With what you are trying to configure, you shouldn't need to touch anything to do with port forwarding or DHCP on the TP-Link - assuming that is currently your main router. The router that is connected to the internet through your ISP will just continue to do whatever it has already been doing.

If the Linksys is your downstream router that is where you may need to configure DHCP forwarding or a DHCP relay if the Linksys is going to distribute IP addresses to devices plugged into the Linksys leased from the DHCP server on the TP-Link.

If Router A (TP-Link) is currently acting as a DHCP server and a device running a DHCP client plugs into the network it should successfully get a lease from Router A. If you attach a second router B (Linksys) to your network it should have static network entries and not be running a DHCP server because two DHCP servers on the same network would be a bad thing. So, it is good practice to forward any address requests that may hit Router B through the gateway to Router A - a DHCP relay.

Not all of the router manufacturers use exactly the same terminology. If the OBI and the Linksys are setup with suitable static IP, DNS and gateway entries, and nothing else is connected to your network using the Linksys, you may not even need to turn on DHCP relay.

I'm hoping this helps answer your specific question about DHCP forwarding. I know there is a lot of potential for confusion when more people get involved in answering a thread. As vango mentioned, I'm not sure that 2 routers is going to help here. It may just add another layer of complexity.

You may want to pull out a scratch pad and actually draw out how things need to connect before making too many changes to entries on your devices.

Last edited by envirogeek; 2013-01-20 at 01:33 AM. Reason: typos
envirogeek is offline  
post #12 of 13 (permalink) Old 2013-01-20, 02:28 PM
Join Date: Jun 2011
Location: 43° N, 81.2° W
Posts: 8,509
Forget what I said earlier. Just follow the instructions for setting up the VPN.
ExDilbert is offline  
post #13 of 13 (permalink) Old 2013-01-20, 07:00 PM Thread Starter
Join Date: Jan 2013
Posts: 9
Well, I've got my setup to work and I didn't have to turn the NAT or DHCP off on the second router. But that's not to say that I won't have any problems with this down the road. All I know is right now I have my DNS service on and my voip.ms phone line is working as I beleive it should be.

My current setup is as follows:

Modem (ethernet to internet)---> Linksys (ethernet to internet)---> TP-Link

Connected to the Linksys I have my OBi100 ATA
I have setup the Primary and Secondary DNS in the TP-Link configuration.

Tested the phone and it works and tested the internet by checking out Hulu and I had no problem accessing video.

I beleive the reason I had issues previously with the phone was because I didn't have the Servers aligned between the OBi100 and my voip.ms account. I have fixed it last week but never tried it because I thought it had more to do with the way my routers were configured. Anyways I don't know that for certain but it would be my guess since that is the only difference I can think of from when I originally set it up.

At any rate I want to thank everyone for giving me their advice.
dragonfyre77 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome