play h.264 gives panning judder - Canadian TV, Computing and Home Theatre Forums
 
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 9 (permalink) Old 2008-01-14, 11:16 AM Thread Starter
 
Join Date: Feb 2006
Posts: 138
play h.264 gives panning judder

I have my Linux box connected to my TV (720p set) via a component cable. I have an nvidia 7600 GT video card.

I have files encoded H.264 codec. I notice significant panning judder. I use mplayer and vlc to play the movies.

The video is 23.976 fps and nvidia has my TV at 60 HZ.

How can I reduce the judder? Any way?
jjinbarrie is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 2008-01-14, 04:13 PM
rpr
 
Join Date: Nov 2006
Location: Brampton, ON
Posts: 484
Which version of the Nvidia drivers are you using, what Linux distribution, and what are the computer hardware specs?

Tom
rpr is offline  
post #3 of 9 (permalink) Old 2008-01-14, 04:44 PM Thread Starter
 
Join Date: Feb 2006
Posts: 138
Hi :

I am using Nvidia drivers 100.14.19. My system is a Gentoo system.

Here's my cpuinfo:

Code:
cat /proc/cpuinfo
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 15
model           : 55
model name      : AMD Athlon(tm) 64 Processor 3700+
stepping        : 2
cpu MHz         : 2204.649
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt lm 3dnowext 3dnow up pni lahf_lm ts fid vid ttp
bogomips        : 4412.24
clflush size    : 64
I also have 2 GB Ram.

My CPU usage is about 20 - 30 % when playing my mkv files.

Relevant part of my xorg.conf:

Code:
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Mag"
    ModelName      "Proview"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "nVidia Corporation"
    BoardName      "GeForce 7600 GT"
    BusID          "PCI:2:0:0"
    Option         "TwinView"
    Option         "TwinViewOrientation"      "RightOf"
    Option         "UseEdidFreqs"             "True"
    Option         "ConnectedMonitor"         "CRT-1, TV"
    Option         "MetaModes"                "CRT-1: 1440x900, TV: 1280x720"
    Option         "TVStandard"               "HD720p"
    Option         "TVOutFormat"              "COMPONENT"
    Option         "AddARGBGLXVisuals"        "True"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1440x900"
    EndSubSection
EndSection

Section "Extensions"
    Option "Composite" "Enable"
EndSection
BTW, this is not video tearing, as I have Sync To VBlank set in my nvidia settings in my KDE autostart.

Last edited by jjinbarrie; 2008-01-14 at 04:51 PM.
jjinbarrie is offline  
 
post #4 of 9 (permalink) Old 2008-01-14, 04:53 PM
 
Join Date: Apr 2005
Location: GTA, Ontario
Posts: 785
Horizontal panning judder is normal for a movie material (24fps) on the monitor with 60Hz refresh rate though (2:3 pulldown needs to be applied)...
testikoff is offline  
post #5 of 9 (permalink) Old 2008-01-14, 04:55 PM Thread Starter
 
Join Date: Feb 2006
Posts: 138
Ya, thats what I reading.
jjinbarrie is offline  
post #6 of 9 (permalink) Old 2008-01-14, 05:03 PM
 
Join Date: Apr 2005
Location: GTA, Ontario
Posts: 785
Quote:
Originally Posted by jjinbarrie View Post
Ya, thats what I reading.
But the judder should not be very significant IMO...
testikoff is offline  
post #7 of 9 (permalink) Old 2008-01-14, 06:00 PM Thread Starter
 
Join Date: Feb 2006
Posts: 138
My wife does not notice, but i do.

Ah well. I guess I have eagle eyes.
jjinbarrie is offline  
post #8 of 9 (permalink) Old 2008-01-17, 09:24 PM
Veteran
 
Join Date: Nov 2004
Location: Fredericton, NB
Posts: 3,185
Quote:
Originally Posted by jjinbarrie
My wife does not notice, but i do.

Ah well. I guess I have eagle eyes.
I can see that kind of thing too so you are not by yourself. And my wife never notices either.
que3jxp is offline  
post #9 of 9 (permalink) Old 2008-01-17, 09:44 PM
Veteran
 
Join Date: May 2006
Location: Calgary
Posts: 1,700
The problem is film based material is 24 fps, and you are trying to convert it to 60 fps. Because of this, each odd frame is displayed longer than the previous frame. Frames are displayed 2 times, then 3 times, then 2, 3, etc... hence you will see judder in slow panning shots. The only real way to get rid of this is to get a 120Hz LCD TV, so that each frame is displayed 5 times, so no motion judder will be seen.
rsambuca is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome