7.1 Surround and AppleTV 4k - Canadian TV, Computing and Home Theatre Forums
 1Likes
  • 1 Post By ExDilbert
 
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 10 (permalink) Old 2017-10-29, 07:38 AM Thread Starter
 
Join Date: Oct 2006
Posts: 121
7.1 Surround and AppleTV 4k

I just upgraded to the AppleTV 4k, and upgraded my receiver to a Denon 720w that supports 7.1 surround.

I downloaded directly from Dolby an audio test file. With my AppleTV audio set to "best quality" and "auto", both the side and rear sounds were being played through my side speakers... nothing was output from my rear speakers.

Using the test tone features in the Denon receiver directly, I can confirm that all speakers (included the rear speakers) are working perfectly. Therefore I don't think it's the receiver but the AppleTV (hence posting here and not in a different forum).

Any thoughts?
drjohnnyfever is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 2017-10-29, 11:54 AM
Veteran
 
Join Date: Jun 2011
Location: 43° N, 81.2° W
Posts: 8,129
How are they connected and what are the audio setting on the Apple and Denon?
ExDilbert is offline  
post #3 of 10 (permalink) Old 2017-10-29, 01:17 PM Thread Starter
 
Join Date: Oct 2006
Posts: 121
They're connected via HDMI (the only output on the AppleTV 4k), and the settings are...

AppleTV 4k: Auto & Best Quality (which I understand means it won't down mix to 5.1)
Denon: Auto (which I understand means it will automatically switch to the appropriate mode)
drjohnnyfever is offline  
 
post #4 of 10 (permalink) Old 2017-10-29, 02:05 PM
57
Moderator
 
Join Date: May 2002
Location: Toronto, Rogers, 9865 & 8300-eHDD, Sharp LC75N8000U, Denon AVR4310Ci; Sony KDL40W3000, 9865
Posts: 56,148
In the Denon menu check:

1. Speaker Setup - Speaker Config - Surround Back should probably be set to "small". Make sure it's not set to "none".

2. Surround Mode - Standard?

57's Home Theatre (Latest equipment & photos)
57 is offline  
post #5 of 10 (permalink) Old 2017-10-29, 02:58 PM Thread Starter
 
Join Date: Oct 2006
Posts: 121
1. Surround backs are set "small".

2. The surround mode is set to "auto". The manual defines "auto" as:

"In this mode, the type of digital signal input, such as Dolby Digital, Dolby TrueHD, Dolby Digital Plus, Dolby Digital EX, Dolby Atmos, DTS, DTS-HD, DTS:X, DTS-ES, PCM (multi-channel) is detected, and the playback mode switches automatically to the corresponding mode. If the input signal is analog or PCM (2-channel), stereo playback is used. For Dolby Digital or DTS, the music is played back according to the respective channel number."

"Auto" seems like the smart choice since my library is a mix of stereo, 5.1, and 7.1. I don't want to have to change modes (or try to remember which files require which mode) every time I play my media.

I should also add that it doesn't matter what surround mode I pick. This is happening in all modes (except 'virtual' where it fakes 7.1).
drjohnnyfever is offline  
post #6 of 10 (permalink) Old 2017-10-29, 04:21 PM
Veteran
 
Join Date: Jun 2011
Location: 43° N, 81.2° W
Posts: 8,129
Is there a way to check what audio the AVR is getting from the Apple TV? On my AVR that is done by pressing the Info button. It shows which channels are active on the input and output. That will determine when the Apple TV is sending DD7.1 to the AVR.

I use Dolby Digital EX. It synthesizes DD7.1 from DD5.1 on those signals and uses DD7.1 when it exists. If it receives a stereo signal it will attempt to decode it. That may or may not be desirable. A stereo signal could be a DD Pro Logic encoded surround stream or it could be an actual stereo stream.
drjohnnyfever likes this.
ExDilbert is offline  
post #7 of 10 (permalink) Old 2017-10-29, 09:30 PM Thread Starter
 
Join Date: Oct 2006
Posts: 121
BINGO! The "info" button showed me the problem!

The Audyssey setup had identified those speakers as "dolby front" under "amp assign". I didn't realize this until I pressed "info" and saw that my rear speakers weren't active at all. I went into "amp assign", changed it to "surround back", and VIOLA! 7.1 surround sound.

Thanks ExDilbert for the suggestion
drjohnnyfever is offline  
post #8 of 10 (permalink) Old 2017-10-29, 11:37 PM
57
Moderator
 
Join Date: May 2002
Location: Toronto, Rogers, 9865 & 8300-eHDD, Sharp LC75N8000U, Denon AVR4310Ci; Sony KDL40W3000, 9865
Posts: 56,148
I find it very strange that Audyssey misidentified those speakers and that the "Speaker Config" didn't show the problem. Also strange that the test tones sent sound to those speakers (in the proper order with graphics?) if they were misidentified and mis-configured... Glad you solved the problem.

57's Home Theatre (Latest equipment & photos)
57 is offline  
post #9 of 10 (permalink) Old 2017-10-30, 06:05 AM Thread Starter
 
Join Date: Oct 2006
Posts: 121
Agreed. It was the test tones that really confused me... the fact they fired properly had me convinced it was the AppleTV and not the receiver.

EDIT: On second though, maybe it's not that strange that the test tones were working. Perhaps in the Denon's mind, the test tones are merely for checking wire connections (and volume levels) and therefore makes all speakers active regardless of setup. I suppose Denon doesn't want to make assumptions about the content you'd be playing later when testing?
drjohnnyfever is offline  
post #10 of 10 (permalink) Old 2017-10-30, 05:51 PM
Veteran
 
Join Date: Jun 2011
Location: 43° N, 81.2° W
Posts: 8,129
Running the test tone diagnostics should have identified those speakers as front speakers and not rear surrounds. Very odd.
ExDilbert is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome