Using own router with MTS fibre internet - Canadian TV, Computing and Home Theatre Forums
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 7 (permalink) Old 2013-09-07, 03:45 PM Thread Starter
Join Date: Sep 2013
Posts: 9
Using own router with MTS fibre internet

I just had MTS fibre internet installed in my home, no TV or phone service. They installed a Lucent Alcatel ONT and a Pace 5168N router. I would like to use my own router. I know that I can enable DMZ Plus mode on the Pace router, but I would prefer to eliminate it completely as many people do in similar situations with Bell, Verizon, etc.

The Pace router is simply configured for DHCP on the WAN port, no PPPoE or anything like that. Plugging my own router into the same port on the ONT does not work, it does not get a DHCP address even with the MAC address from the Pace router cloned. I suspect MTS' network is either filtering by something else in the DHCP request, or there is some VLAN tagging going on (as reported in the Bell forum). I attempted to use a packet sniffer between the ONT and Pace modem but going through my managed switch the Pace router is not getting a DHCP lease from the ONT. It only works when the Pace router is directly connected to the ONT.

I am in the process of finding a plain hub to try packet sniffing again, but I figured I would post here to see if anyone has had success with bypassing the Pace router completely.
kaziboler is offline  
Sponsored Links
post #2 of 7 (permalink) Old 2013-09-08, 10:34 PM
Join Date: May 2010
Posts: 76
Did you reboot everything after plugging in? When I installed MTS I used to plug my laptop directly into the ONT and be able to surf. Now i work at TELUS and we sometimes go from the ONT to a gigabit switch, out to a customer's router on one port and out to our gateway for our tv service on another so the customer has a direct connection to the internet.
mtsguy is offline  
post #3 of 7 (permalink) Old 2013-09-08, 10:41 PM Thread Starter
Join Date: Sep 2013
Posts: 9
I did try rebooting everything. The installer said that used to work but wasn't sure if it did anymore. A bit more information: if I plug the ONT and the Pace router into my managed switch nothing works, but if I plug them into an unmanaged switch it works. This tells me that vlan and priority are important since the managed switch is likely striping these. I don't have a regular hub but from what I have seen, the DHCP packets from the Pace router are tagged with vlan 0 and priority 3. Unfortunately I haven't been to replicate this with my own router for now.
kaziboler is offline  
post #4 of 7 (permalink) Old 2014-01-25, 12:18 PM
Join Date: Jan 2014
Posts: 1
MTS Using own router

I think i have the answer for you. I have the MTS ONT going throught a cisco switch then to my router on its own vlan. It took some heavy troubleshooting but here is what i did. The port on the switch which is connected to the modem needs to be a trunk port. I posted my config of my 2 ports:

interface GigabitEthernet0/19
description Connection to Mikrotik Router
switchport access vlan 15
spanning-tree portfast
interface GigabitEthernet0/20
description Connection to MTS Fion Modem
switchport trunk encapsulation dot1q
switchport trunk native vlan 15
switchport trunk allowed vlan 15
switchport mode trunk
spanning-tree portfast

This allowed me to go through my switch and router grabbed the same ip address as before.

Hope this helps.
cisco_guy is offline  
post #5 of 7 (permalink) Old 2015-03-09, 05:12 PM
Join Date: Mar 2015
Posts: 1
So, my understanding is that you went from your ONT to your Cisco Switch, port 20 (making it a trunk port), and then port 19 goes to your Mikrotik router, and that works? No Pace 5168N involved at all?

Do you know if MTS is universally VLAN 15? Or have you not had a chance to test it on other equipment?
Zergo is offline  
post #6 of 7 (permalink) Old 2015-06-29, 12:15 PM
Join Date: Jun 2015
Posts: 1
I successfully used my own router. You need to clone the previous MTS router MAC address, as well strip vlan off of the connection to the fion modem.

In my particular case, I have a buffalo (N600) router flashed with dd-wrt. It does not support vlan, only tagging. So I presume it ignores/strips vlans off of incoming connections (Im guessing, I dont know a great about of vlans). And like I said above, I also cloned the MAC address. With dhcp for the WAN port, it pulls an ip and works great!
CodyM is offline  
post #7 of 7 (permalink) Old 2017-04-21, 08:27 PM
Join Date: Sep 2014
Location: Manitoba Canada
Posts: 7
Currently I have been able to completely remove my Pace router on MTS Fion fibre internet by getting the MAC address from the Pace router and cloning it to my New Linksys router. The internet was immediately available. However after a configuration change on the router and a reboot, it took a long time(10-15 minutes) for router to hook back up to the internet. I was considering putting the old router back when the internet came back on.

It seems to be working, but I'm paranoid about why the internet took so long to be available.

I don't understand some of the comments on VLAN configuration, and if that should be done or not. My linksys options are...

any comments and suggestions welcome.

Gorbechauve is offline  

Quick Reply

Register Now

In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome