Canadian TV, Computing and Home Theatre Forums - View Single Post - Small assistance in WDTV Live setup needed
View Single Post
post #1 of (permalink) Old 2012-02-10, 10:02 AM Thread Starter
thebone
 
Join Date: Apr 2010
Posts: 223
Small assistance in WDTV Live setup needed

Hey gang, wondering if you can help me get over a hump here.

I have WDTV installed. Using windows shares I am able to browse my folder my I need some assistance on the next part so I don't go in the wrong direction and have to reformat.

I have an External drive that is my storage drive and I call it S. Inside there i have a truckload of subfolders. What I did was make myself (admin) the owner and of course I have full permissions for the S drive. Admin has full blown everything, whereas the "everyone" account, has read only

After that, I went in and removed permissions from all the subfolders except the ones I want to share on WDTV. IN this case it is TV, Movies, Comics. Everything else I removed permissions from and it has the little padlock.

Now, here is the issue - when I turn on WDTV, after having added the network share, whether I go under Videos or whatever, it shows only the folders I left permissions intact on, but it also shows the S drive which is the parent. I can go in there and browse around freely all the subfolders I removed permissions from.

When I had added the network share on the WDTV I added the admin credentials.

I am guessing because i added the admin account as the WD credentials, I have full blown access to everything.

I am wondering what the best way is to actually restrict it - should i set up another external with only the folder i want to share ? Or is there a way to create a non admin account, sort of a "guest account" on the WD TV so that guest login only sees the shared subfolders ? How would I do that? would i create a gues windows account complete with credentials, then remove my wdtv shares, re-add using the guest windows acct credentials ?
thebone is offline  
 
 
For the best viewing experience please update your browser to Google Chrome