Oh no, my SVS Sub is crackling! - Canadian TV, Computing and Home Theatre Forums
 

Go Back   Canadian TV, Computing and Home Theatre Forums > Consumer Electronics and Home Computing > Home Theatre Corner

Reply
 
Thread Tools Search this Thread Display Modes

Old 2012-05-05, 03:01 PM   #1
ogradyt
 
Join Date: Apr 2005
Location: Calgary
Posts: 19
Unhappy Oh no, my SVS Sub is crackling!

Hi,

My two year old SVS PB12-Plus sub started crackling earlier in the week, so I turned it off and waited for the weekend to take a look.

Ran the Avia LFE sweep just now and the sub is crackling like rice crispies through the whole sweep. Plugged the subwoofer cable into my Mirage OM-6's and they handle the LFE sweep just fine, so I don't think it is the cable, amp or the source itself.

Anyone know what the problem might be? Have any suggestions of things to try?
ogradyt is offline  
Sponsored Links
Advertisement
 
Old 2012-05-05, 06:07 PM   #2
Mr Canoehead
 
Join Date: Feb 2004
Location: Ottawa
Posts: 99
Default

Try another cable, make sure nothing is touching the wire.
Mr Canoehead is offline  
Old 2012-05-05, 06:52 PM   #3
eljay
DHC Supporter
 
Join Date: May 2003
Location: Ottawa (Orleans), ON
Posts: 8,593
Default

Quote:
Have any suggestions of things to try?
Try calling SonicBoomAudio or SVS.
__________________
MY HT SET-UP (PICS & GEAR LIST)
eljay is offline  
Old 2012-05-06, 12:38 PM   #4
ogradyt
 
Join Date: Apr 2005
Location: Calgary
Posts: 19
Default

Thanks eljay, Mr Canoehead.

I did contact SVS and they had me do a couple of things. One was to switch the interconnect, (like Mr Canoehead suggested), and the other was to connect a CD player out directly to the sub. Both scenarios still had crackling.

SVS then referred me to Mason at SonicBoomAudio for warranty service. It will be interesting to see how this goes.

The response time from SVS was under 30 minutes from the time I sent them the email on a Saturday. Very impressive.
ogradyt is offline  
Old 2012-05-07, 10:05 AM   #5
Mr Canoehead
 
Join Date: Feb 2004
Location: Ottawa
Posts: 99
Default

I bought mine about the same time so I hope it's not contagious!
Mr Canoehead is offline  
Old 2012-05-11, 06:38 PM   #6
ogradyt
 
Join Date: Apr 2005
Location: Calgary
Posts: 19
Default

Just so you know, Mason from sonicboomaudio contacted me pretty quickly and found an amplifier in stock so I am shipping him the plate amplifier, and he will ship me back a replacement. Way better than shipping the whole sub around.

For those of you who are curious, I have posted a picture of the amp. I believe it is 525watts for this generation of the PB12Plus.
ogradyt is offline  
Old 2012-05-11, 08:19 PM   #7
pharsyde
DHC Supporter
 
Join Date: Nov 2008
Location: St John's
Posts: 609
Default

Nice job. Am not surprised regarding SonicBoom, Mason's a good young fellow.
__________________
Anthem MRX500 [Processing] | Audio Refinement Multi 5 | OPPO BDP93 | Focal Chorus | JLAudio F110 | 50" Panasonic Plasma | Primacoustic Wall Panels
pharsyde is offline  
Old 2012-05-11, 08:40 PM   #8
eljay
DHC Supporter
 
Join Date: May 2003
Location: Ottawa (Orleans), ON
Posts: 8,593
Default

Quote:
I did contact SVS ... SVS then referred me to Mason at SonicBoomAudio for warranty service. ... The response time from SVS was under 30 minutes from the time I sent them the email on a Saturday. Very impressive. ... Mason from sonicboomaudio contacted me pretty quickly and found an amplifier in stock so I am shipping him the plate amplifier, and he will ship me back a replacement.
SVS - and, to a related extent, SBA - have a solid reputation for customer service. Nice to see that they were able to help you out promptly.
__________________
MY HT SET-UP (PICS & GEAR LIST)
eljay is offline  
Old 2012-06-02, 06:31 PM   #9
ogradyt
 
Join Date: Apr 2005
Location: Calgary
Posts: 19
Default

Just to report back. Mason at Sonicboomaudio sent me a refurb amp the same day he received mine, and I now have a working subwoofer again. Mason even checked to ensure I received the amp.

Very happy with the warranty service I received from sonicboom/SVS.
ogradyt is offline  
Old 2012-06-11, 01:08 PM   #10
caper_26
 
Join Date: Feb 2010
Location: Cape Breton, NS
Posts: 223
Default

did they provide feedback on the amp you sent in ? Glad to hear you got it up and running again... sigh of relief huh?
__________________
47LG55|RX-V565|HD DVR|PS3|Wii|3XEnergy Take FPS|2 VS|2 X LCR|DIY SDX-12|DIY Trio12
RC-70x2|RX-V863|MA RS-w12 Sub
caper_26 is offline  
Old 2012-06-12, 02:50 PM   #11
ogradyt
 
Join Date: Apr 2005
Location: Calgary
Posts: 19
Default

No, they haven't provided feedback, but good idea, I might just ask them. It was a sigh of relief.
ogradyt is offline  
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -4. The time now is 06:33 AM.

Search Digital Home

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.