Canadian TV, Computing and Home Theatre Forums - Reply to Topic
Thread: Problem with Shaw High Speed Internet CS Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
2007-07-25 06:30 PM
jumpy27
Problem with Shaw High Speed Internet CS

I had a problem about 3 weeks ago with surfing on the internet. I could download bittorrents and large PDF files normally, but I couldn't surf at all. I phoned Shaw and they said no one else was having any problems. The next day it worked fine.

Fast forward to 3 days ago in the evening. Surfing was impossible, but downloads seem to work normally. I phoned Shaw at 12 noon the next day and I spent about 40 minutes on the phone trying different things with my computer which made no difference. He then suggested defragging the hard drive which took about 3 hours as I had to move a number of files over to DVD because the hard drive was 90% full. It took couple of hours to defrag which of course made no difference.

I phoned back at 8PM the same day and was told that there WAS an issue in my area, and they knew about it since LAST night, but that due to "office politics" they didn't let their customers know right away that that the problem was on their end. I find this very frustrating as I wasted all this time and I also didn't know if there was something wrong with my computer. All Shaw had to do was tell me that the problem was on their end and they were working on it as we spoke. I wouldn't have wasted my valuable time that day trying to fix something that wasn't broken (at least on my end). I use the internet for my repair business, and when it doesn't work I have to try to get it going ASAP. I thought that only Bell did things like this. Shaw is famous for their good customer service. But this time they dropped the ball.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome