Canadian TV, Computing and Home Theatre Forums - Reply to Topic
Thread: 8642HD - PCM Audio Over HDMI Reply to Thread
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:

Register Now

In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
2016-03-10 01:31 AM
8642HD - PCM Audio Over HDMI

I'm suddenly not getting ANY audio over HDMI with this 8642. It was working one night then the box started downloading an update so I had to stop watching TV and go to bed. Next day the audio was gone.

I've rebooted, checked my settings and swapped cables but the only way to get audio is to hook up a coax cable (in addition to the HDMI for video). I think the HDMI output is defective.
2015-02-05 02:36 PM
ExDilbert It's nice to know that it works as it should. Ideally, turning devices on and off should not be required. In addition to overrides, there should be an auto-negotiation mode which enables audio and video negotiation dynamically as devices become available. It seems to work one way but not the other. This could be a shortcoming in the HDMI spec.
2015-02-03 11:42 PM
57 I believe the issue was actually fixed. The firmware now sends the "correct" signal depending on the device the PVR is connected to. If I turn my TV on first the PVR sends a PCM signal to it, as it should. If I turn my AVR on first, the PVR sends a DD signal to it, as it should. If I forget to turn my AVR on first, I get a PCM signal and I need to turn the PVR off, leaving the AVR on, then when I turn the PVR on again, I get proper DD. If you want to override the signal, then you need to do as indicated in post 8.
2015-02-03 11:34 PM
ExDilbert This may be a side effect of Rogers "fixing" the switching to PCM issue. Now it's a switching to Dolby issue. Nothing was really fixed, the issue was just masked by creating another.
2015-02-03 09:29 PM
Lamzyc I've been having this problem too on my 9865.

I have found a workaround that works every time.

Go to Settings-Audio.

Audio Output will be set to Other.

Switch it to Dolby. Save. Then switch it back to Other.

Voila, PCM 2.0 working. Significantly louder than the 5.1 feed (with audio range set to Narrow, as I prefer it).

You will have to repeat this every time the box reboots.

It seems the audio hardware and the UI are somehow out of sync with each other.
2014-12-01 07:07 PM
pkcrawford OK, so it looks like the root cause is the Nextbox not switching out of DD mode. At least I know it is not just me. The TV can't force PCM on it's digital output, but I am able to do the work around with the TVs analog output.
I use the sound bar to switch between multiple audio sources and using the TVs digital output is optimal in my setup. I'll need to jump through a few hoops to get everything going. It is just too bad that the Nextbox isn't doing something I took for granted it would do.
Any chance this will get fixed in the next firmware release?
2014-12-01 03:32 PM
57 If the above suggestions cannot be made to work, use analogue audio cables from the 8642 to the sound bar. They should be active at all times, although no guarantees.
2014-12-01 01:30 PM
gdkitty That was my next thought.

See if the TV has a supported PCM only output setting.

Analog RCA should also work.. Would FORCE it to stereo, and could STILL then use HDMI for the regular VIDEO/AUDIO to the TV.
2014-12-01 10:51 AM
ExDilbert I noticed a similar thing with the 9865. They run the same firmware so they should act the same. Setting the audio to PCM resulted in DD still being active. I've got to wonder if this is how they fixed the "switching to PCM" issue that was reported with previous firmware. If so, it didn't really fix anything. It just masked one problem by creating another.

pkcrawford, does the TV have an option to output only PCM? Does it have analog RCA outputs that could be used?
2014-12-01 10:05 AM
pkcrawford Thanks 57. I tried all of you tips, but no luck I was hoping that someone can confirm they actually have PCM over HDMI working so that I can blame my TV and not the 8642HD. I feed my TV with HDMI from the 8642HD and send the audio from the TV over to my sound bar using toslink. Unfortunately, my sound bar does not support DD, hence the need to go PCM. My other HDMI devices send the PCM no problem, but no luck with the HD box.
Can anyone actually confirm one way or the other if they have PCM working over HDMI? I would hate to revert to component unless I really have to.
2014-12-01 08:16 AM
57 Reboot? Also make sure you have HDMI-CEC turned off on whatever devices are connected to the PVR, otherwise the HDMI "handshake" may override any settings. See point 4 of the HDMI FAQ:

It's possible that despite doing everything right (disabling HDMI-CEC, etc), the 8642 may send DD due to the HDMI handshake that occurs each time the devices are turned on.

Why would you wish to invoke PCM on the 8642? It is an inferior signal on the STB since it's downconverting the original DD signal, thus losing you the discrete channel information present in that DD signal. If you have a valid and necessary reason for invoking PCM, then you may need to use component video and optical audio connections.

Although PCM is often considered a "superior" signal to DD since it can be lossless as in a CD or BD (LPCM), it becomes "lossy" and inferior if it's being downconverted from a DD signal, as would happen in a STB.
2014-12-01 12:20 AM
8642HD - PCM Audio Over HDMI

Can anyone with a Cisco 8642HD confirm if they are able to get 2 channel PCM audio over HDMI? I have the audio set to "other", but I am still receiving Dolby Digital audio. Any tricks for getting the box to send just PCM?

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

For the best viewing experience please update your browser to Google Chrome