Mini Camera Drivers For Win XP? - Canadian TV, Computing and Home Theatre Forums
 
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 9 (permalink) Old 2008-06-29, 11:55 AM Thread Starter
 
Join Date: Jan 2008
Posts: 442
Question Mini Camera Drivers For Win XP?

I picked up one of those cheap mini keychain digital cameras that were on sale a while back at Canadian Tire just to see what kind of picture quality they're capable of. (Not that my expectations were set high to begin with.)

The camera has it's own unique mini USB cable with it (which will come in handy in identifying it among the other 537 varieties I also have ) and the standard male plug at the other end. I plugged the cable into the computer and a "New Hardware Found" message popped up followed immediately by a "Dual Mode Camera" message. (It can also function as a webcam.) XP then went about searching for the appropriate drivers to install, but it came up empty.

I then put the CD that came with the camera in and tried to install the drivers this way. Still nothing. I then noticed under the Drivers sub-folder that there was only a setup.exe file. I ran it and the program then proceeded to install the necessary drivers. Upon completion, a new icon to a program called MarsCam ICF was present on the desktop. After clicking on it, I discovered this was photo management software for this particular camera. When I tried to get it to read the contents of the camera however, I was told that the driver installation had failed and the program had to be shut down. I then tried to re-install the drivers and the same thing happened. I removed the "Camera Driver" listing through Add/Remove Programs, re-installed again and still the same result. I next went on search of updated drivers in Cyberspace only to find many other examples of people having the same trouble with mini cameras on XP, but no solutions that have yet to work for me.

Has anyone else had this problem with a mini camera on XP? Usually any drivers required to use a digital camera are automatically installed by XP and this is the first time I have ever seen XP not be able to automatically locate drivers for a peripheral device. What makes it even more baffling is that is clearly says in the instructions:

If you want the photos in the camera to be downloaded into your computer, you are only required to connect the USB cable to your computer and your camera.

Not so in my particular case. This is a BELL brand camera (not in any way related to the phone company) from Bell Automotive Products, Inc. of Des Moines, IA. While this product is listed on their website...

http://www.bellautomotive.com/asp/pr...s.asp?id=25429

...I cannot find any mention of drivers for it there either.

While I may have overlooked or completely missed something that would solve this little nuisance, as always, any insight and assistance from any and all here is greatly appreciated.
FLACer is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 2008-06-29, 01:05 PM
Veteran
 
Join Date: Apr 2007
Location: Whitby
Posts: 2,815
I have one of those from xscargo - they're all the same.
I'll upload the drivers for you, see if my version works.
I never used it for photos, just a crappy (at best) webcam

Here you go:
http://dvrmstompeg.googlepages.com/setup.zip
recneps77 is offline  
post #3 of 9 (permalink) Old 2008-06-29, 01:24 PM Thread Starter
 
Join Date: Jan 2008
Posts: 442
Post

Thank you recneps77.

I'm not at my computer at the moment, but I'll download these as soon as I can and I'll let you know what happens. Hopefully they'll do the trick.
FLACer is offline  
post #4 of 9 (permalink) Old 2008-06-30, 06:21 PM Thread Starter
 
Join Date: Jan 2008
Posts: 442
Unhappy No Dice

Thank you again for your assitance recneps77, but unfortunately this didn't work.

The MyDSC2 and PC Cam software installed alright, and when I plugged the camera into the USB port, again the "New Hardware Found" message popped up followed immediately by a "Dual Mode Camera" message. However, also no luck in searching for the drivers. This time though, I did notice the following message:

Cannot Install This Hardware

The hardware was not installed because the wizard cannot find the necessary software.

Any other suggestions?
FLACer is offline  
post #5 of 9 (permalink) Old 2008-06-30, 11:21 PM
Veteran
 
Join Date: Apr 2007
Location: Whitby
Posts: 2,815
Hmm.. it should have installed any required driver to c:\windows\twain_32\MYDSC2\INF
If this folder exists, try pointing the 'add new hardware' wizard there.

Mine works after installing the above file (at least it installs the drivers)
The camera appears to be dead though, all I get is a flashing black/red fuzzy picture, lol. (Could be this laptop though...)
recneps77 is offline  
post #6 of 9 (permalink) Old 2008-07-15, 01:28 PM Thread Starter
 
Join Date: Jan 2008
Posts: 442
Post

Quote:
Originally Posted by recneps77 View Post
Hmm.. it should have installed any required driver to c:\windows\twain_32\MYDSC2\INF
If this folder exists, try pointing the 'add new hardware' wizard there.
I did exactly as you suggested and I still get the same error message.

I checked the above folder and the files that appear are:

sq905c.cat
SQ905C.inf

Is there something missing? Any other suggestions? (I've got a dead blow maul from Princess Auto I've been wanting to try out on something for a while now. )
FLACer is offline  
post #7 of 9 (permalink) Old 2008-07-15, 02:14 PM
Veteran
 
Join Date: Apr 2007
Location: Whitby
Posts: 2,815
Nope, just those 2 files.

I think you should prepare to smash
Its not like this camera is worth a lot anyway, might as well have some fun with it!
recneps77 is offline  
post #8 of 9 (permalink) Old 2008-07-15, 02:25 PM Thread Starter
 
Join Date: Jan 2008
Posts: 442
Post

Yeah and I could use the camera to take a picture of me using the maul to smash it and then...

Wait a second now, I think there's a flaw in my logic there.

Seriously though, other than the fact that it could be a defective camera, I really don't know what the problem could be.
FLACer is offline  
post #9 of 9 (permalink) Old 2009-04-21, 01:17 AM
Rookie
 
Join Date: Apr 2009
Posts: 1
mini marscam 'driver fail' messages

For all those who bought the keychain cams...

Plug in Camera, go to the Device Manager, Imaging Devices, and “update” the camera’s driver, select the unzipped file location you chose, go.
fingers88 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome