Samsung DLP issue - light won't fire - Canadian TV, Computing and Home Theatre Forums
 
LinkBack Thread Tools Search this Thread Display Modes

post #1 of 12 (permalink) Old 2011-04-06, 12:29 AM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
Samsung DLP issue - light won't fire

Wel I was having some color issues so I ordered a new color wheel and when I replaced it I put everything back together and the lamp will not fire and the lamp light just flashes on the front power button. So I figured I jacked up my lamp during the color wheel replacement so I ordered a new one. Put it in today and got the same result. What is my issue? I plugged everything in correctly and didn't break anything.
bigred76 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 2011-04-06, 12:32 AM
57
Moderator
 
Join Date: May 2002
Location: Toronto, Rogers, 9865 & 8300-eHDD, Panasonic TCP65S1, Denon AVR4310Ci; Sony KDL40W3000, 8300-eHDD
Posts: 53,485
Sometimes when people reassemble things, they don't put the access "door/panel" back correctly (or something else) and the "switch" still thinks the door is open and won't fire the lamp for safety reasons. Check to make sure the "switch" contacts for the door are being properly closed. (Similar to the switch in your fridge that senses when the door is closed and turns the light out).

57's Optimization Services (Home Theatre Optimization) . . . . 57's Home Theatre (Latest equipment & photos)
57 is offline  
post #3 of 12 (permalink) Old 2011-04-06, 12:48 AM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
I see the door switch and have it up but still doesn't fire.
bigred76 is offline  
post #4 of 12 (permalink) Old 2011-04-06, 12:55 AM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
It clicks and the fan for the bulb is on but not fire. It's like the starter is bad. It was working fine besides the color being a little messed up before I changed the color wheel. After I changed the wheel I have no light.
bigred76 is offline  
post #5 of 12 (permalink) Old 2011-04-06, 12:58 AM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
It's flashing Lamp, Stand By Temp, and timer all at the same time.
bigred76 is offline  
post #6 of 12 (permalink) Old 2011-04-06, 08:22 AM
 
Join Date: Aug 2002
Location: Calgary, Alberta
Posts: 1,122
Greetings

Other things that might work ... unplug the tv for a while and then plug it in. May need a boot up.

I had done a lamp replacement on an LG dlp unit recently and the bulb would not fire. Unplugged it ... waited a few minutes ... tried again and the bulb fired and all was well.

How many hours are on the bulb anyway? Don't rule out the possibility that the bulb has simply expired too.

regards

Michael @ TLVExperience
ISF/THX Video Systems Instructor
Michael TLV is offline  
post #7 of 12 (permalink) Old 2011-04-06, 09:02 AM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
Well I replaced the color wheel and put it all back together and it would not fire the bulb. So it was flashing bulb so I figured that I may have jacked the bulb up when removing it. So I ordered a new lamp and housing. Put it in and now I get all three flashing. So I have a new color wheel and new lamp with housing put in.
bigred76 is offline  
post #8 of 12 (permalink) Old 2011-04-06, 10:14 AM
57
Moderator
 
Join Date: May 2002
Location: Toronto, Rogers, 9865 & 8300-eHDD, Panasonic TCP65S1, Denon AVR4310Ci; Sony KDL40W3000, 8300-eHDD
Posts: 53,485
If the unplugging mentioned by Michael doesn't work, sometimes there's a reset procedure to set the "hours of use" meter back to zero so that you can tell how many hours are on the (new) bulb. This procedure is usually outlined in the operating manual, or sometimes in the instructions for bulb replacement that come with the bulb.

I'm not an expert on these units - perhaps send an e-mail to Samsung support to see what they say - indicate all that you've done and what the TV is doing now in detail (or give them a call).

57's Optimization Services (Home Theatre Optimization) . . . . 57's Home Theatre (Latest equipment & photos)
57 is offline  
post #9 of 12 (permalink) Old 2011-04-06, 05:44 PM
 
Join Date: Oct 2004
Location: Winnipeg
Posts: 240
I just replaced my Samsung DLP bulb recently and had issues with the new bulb turning off intermittently. I resealed the lamp door/switch and this solved my problem.

If your old color wheel was working partially, why not just re-install it temporarily to confirm that the new wheel isn't faulty?
vango44 is offline  
post #10 of 12 (permalink) Old 2011-04-07, 01:27 AM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
Well guess what? I put the old color wheel back in and it works. Time to return the new one. Thanks for the help!!!!
bigred76 is offline  
post #11 of 12 (permalink) Old 2011-04-14, 12:19 PM Thread Starter
Rookie
 
Join Date: Apr 2011
Posts: 7
Well spoke with a Samsung tech and he told me that I needed to use my old color wheel housing and take the new color wheel and put it in it since the new house is a little off which makes the wheel hit and won't spin so the lamp won't come on. I did what he said and it came right on.
bigred76 is offline  
post #12 of 12 (permalink) Old 2011-04-14, 05:42 PM
 
Join Date: Oct 2004
Location: Winnipeg
Posts: 240
Thumbs up

Cool! Good to know if I never need to do that.

Thanks for posting back with the resolution.
vango44 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Canadian TV, Computing and Home Theatre Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome